Forum / Password Vault Manager - Support

browser extensions...confusing and not much use really

Well firstly I'd like to say PVM looks to offer the more features than any other password manager... secure RTF notes look great, being able to nominate a specific browser to open a URL is sadly missing in Roboforms, heaps of config options....but the browser integration is sadly lacking.

Why doe the extension manager provide a link to the Dev Web Login extension and not hte PVM extension??? I have ended up installing both but the Dev Web Lognin extension downt do anything.


I just dont get it, there does not seem to be any way to save a web page url and login details into PVM. This is the MOST FUNDAMENTAL requirement of a browser extension for a password manager yet I cant find any way to do it.
Please tell me you can save a website url and login credential into PVM without reverting to clumsy cut and paste, otherwise I might as well stop evaluating PVM now!

Clock12 mths

Hi,
Something must be missing in our documentation since it should be really simple. First of all you need to remove the Password Vault Manager web browser extension since it's deprecated. All you need is the Devolutions Web Login browser extension. We use to have one extension for RDM and one for PVM. This is no longer the case and Devolutions Web Login can connect to both.

With the extension installed, PVM up to date and running, you should be able to add url and get the credential auto filling.

Regards

David Hervieux

signaturesignature

Clock12 mths

lets give you an example.

Obviously, I had to login to post this question. Well I used my Devolution free cloud account credentials to log into the forum (which are saved in PVM as a Login (Account) type record with no URL). So I lookup PVM to get my credentials, then manually type them into the login fields on the forum page and the moment I hit the "login" button the Roboforms extension pops up asking me if I want to save these login details. I give it a name and click save, and now my Devolution forum's URL login and password is saved (in Roboforms) ready for the next time I want to go back to the forum and read/respond to my post......I havnt noticed PVM popping up asking if I want to save any credentials yet!!!

So this morning I read my email which says I have a reply to my post, so I click on the link, which takes me to the post, but I still need to login. I can use my roboforms extension and login with one click, but the Dev Web Login extension is oblivious to the forum site as there is no PVM record with this URL because it didnt ask me to save it the first time I entered any credentials. So now I have to go back to PVM, manually create login (Web) record, then go back to the browser and copy the URL for the forum login page, then go back to PVM and paste the URL, then get annoyed because the field is way to short to display even a very short URL!@#$, then save the record, then go back to my Dev free cloud account record and copy the login, then open the properties of my newly created record and past the login, save it, then go back to my free cloud account record and copy the password, then go back to my newly created record and re-open the properties and paste the password (NB though the copy login and password button might work... but nope it does not work!)...you get the picture now!

And you have to realise I still havnt logged back into the forum site yet, I'm just creating a record in PVM "to make it easier for the next time"!

Have you any idea of how painful that process is when I can do that with a SINGLE CLICK in Roboforms?

PMV has the potential to be far superior to any of the mainstream password managers out there like Roboforms, 1Password or Keeper, but only when you give us a browser extension that enable the user to capture a web sites URL and credentials. At the moment the browser extension only providing half the functionality of any of the other password managers browser extensions.

Clock12 mths

Ok the plot thickens...

It looks like the Dev Web Logn does infact work both ways..sometimes. I now have the web web login extension sometimes prompting to save a website credentials which is great, but its not consistent. No idea why it haddnt popped up in my previous testing.

Logging into Amazon it prompted to save, but not some other sites I tried. When I then try to open amazon from PVM it opens the website but does not automatically log me in, I then have to manually click on the login button at which point the extension does fill in the fields and I then have to click login manually. Is this the intended method of "semi" auto login?

I also logged out, then back into this forum page and it prompted to save login details, but when I try and open the forum page from the saved record in PVM it give the error message "unable to execute the web browser (forum.devolutions.net). The record I created manually by copying the url works, so the extension is not capturing the full URL for the Devolution forum site!.

Looking better though!

Clock12 mths

Hello Grant,
I have assigned this thread to Olivier. He works full time on the browser extension. You will be able to check with you why it does not work all the time. Be assured that we are really serious with our browser extension. Like you mentioned we believe a lot in it.

Regards

David Hervieux

signaturesignature

Clock12 mths

Great, I'm really excited about PVM, it has some really great features, with heaps of potential, so I'm hanging in there.

Yep now I understand how the "copy login and password" works

Clock12 mths

So is there any way to force a save when on a website that does not have login credentials?

The reason I ask is that I use Roboforms to manage ALL my website favourites regardless of whether they have a login and password.

With the Dev Web Login, it appears that its only triggered when the login and password field is entered. With Roboforms I can click on the extension button in the toolbar, and there is a "Save" button to force the current site to be saved in Roboforms.

Clock12 mths

Hi Grant,

-We are aware that Devolutions Web Login might sometimes not catch that a login happened on some websites and not popup the "Save Credentials" dialog. We are currently investigating it.

-To submit the form, you need to check "Automatically submit the form after fill-in" in the extension options. It will fill the fields and submit the login form and thus automatically log you in.

-I have been able to reproduce your issue with "Unable to execute the web browser" in PVM, we will investigate it.

-We added the New Entry button to add sites from Devolutions Web Login into the data source feature in our TODO list.

Best regards,

Olivier Désalliers

signaturesignature

Clock11 mths

just following up on this one. The web login is still very flaky. Even on your own forum website it only works sometimes.

My forum login record in PVM has the following url: https://forum.devolutions.net/forum30-password-vault-manager--support.aspx

So if I open web browser to the above address the web login extension recognises this address and I can pick my login credentials. However if click on a link in a forum email message that has a url to a specific forum thread, then the web login extension does not show my credentials. I assume this is because it is a different url.

I see in the PMV record edit screen there is an option for "enable web browser extension link", and a compare type: default, compare regex with url or full url

I've tried default and url but makes no difference

I'd guess that less than half of websites I need to log into will work with the web login extension!

Any timeframe for adding a button to the web login extension to save current site to PVM?

Clock5 mths

Hi,

I am not able to reproduce your issue with Devolutions Web Login not able to pick up the credentials when for example clicking a link in a forum email message that has an url to a specific forum thread.

When the compare type is default, PVM is comparing the URL sent by Devolutions Web Login by looking at the URL domain. For example, the URL of this thread is https://forum.devolutions.net/topic27888-browser-extensionsconfusing-and-not-much-use-really.aspx. The domain is forum.devolutions.net and the domain in your session (https://forum.devolutions.net/forum30-password-vault-manager--support.aspx) is also forum.devolutions.net. Because they are matching the credentials should be sent to DWL.

In the case of the regex, it will compare the regex you wrote in the field with the domain (forum.devolutions.net) or with the full URL https://forum.devolutions.net/topic27888-browser-extensionsconfusing-and-not-much-use-really.aspx. One of the reason this feature was created because is possible to have a URL that redirect to a dynamic URL that change the domain by changing for example a number. In your case, you shouldn't need a to use regex because the domain should always be forum.devolutions.net.

For testing purposes, could you try to uncheck "Enable native messaging" in the Devolutions Web Login options?

Would also it be possible to create a short video where you reproduce the issue with the steps? You can send me the video via private message.

About the ability to save the current site in PVM from Devolutions Web Login, it should be in the next Devolutions Web Login minor version that will come out this month.

Best regards,

Olivier Désalliers

signaturesignature

Clock5 mths