Forum / Remote Desktop Manager Mac - Support

SSH Connection to Cisco Switch

  • Create an Issue
  • Cancel

I have not been able to get the SSH functionality on RDM for Mac to work no matter what settings I try. I always get "Error: Unable to establish the connection. Please make sure your connection settings are valid." I have configured the Entry as SSH Shell (Native) and put the IP address of the switch in the Host field and completed my username and password. I am able to SSH to the switch from Terminal using the same credentials without any issues. Any help would be appreciated. I have a colleague using Putty on Windows and he is able to connect.

Clock3 yrs

Hello Jeff,
I will assign this to Xavier and he will be able to help you Monday.

Regards

David Hervieux

signaturesignature

Clock3 yrs

Hi Jeff,

This is weird. Could you give me some info on the server you're attempting to connect to? Running the SSH command while enabling the verbose mode (ssh -v username@host) in the Terminal.app and then sending me the output (via private message) could provide me with relevant info.

Could you also try opening your session in external mode and tell me if it works? You can do this by right clicking on your session and then Open with Parameters -> Open (External).

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hello

I am now getting this reply. The I am able to connect to nexus switches but not to catalyst switches. I have tried changing everything but no joy. someone else in teh office using windows has no issues connecting to the switches.

Was there any fix to this?

Cheers
Gareth

Clock2 yrs

Hi Gareth,

Could you follow the instructions I've mentioned in my previous post?

Could you provide me with more details on your session? Are you using a private key to authenticate? If so what type of key is it?

Can you connect through the the Terminal.app (ssh command)?

If you had any old or test Catalyst switches to which you could grant us access, this could help us reproduce the issue and ultimately fix it.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

Same Problem, seem still not fixed ? Cisco Nexus works fine..
How can i setup rdm to open it external from rdm with terminal or putty for example ?
MacOS Sierra 10.12.6 (16G1114)

Device is a Cisco Catalyst 6513
Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(33)SXH8a, RELEASE SOFTWARE (fc1)

Output from rdm:
Initiating connection
Connecting to 10.30.230.1 : 22
ssh_connect: libssh 0.7.5 (c) 2003-2014 Aris Adamantiadis, Andreas Schneider, and libssh contributors. Distributed under the LGPL, please
refer to COPYING file for information about your rights, using threading threads_noop
ssh_connect: Socket connecting, now waiting for the callbacks to work
ssh_connect: Actual timeout : 10000
ssh_socket_pollcallback: Received POLLOUT in connecting state
socket_callback_connected: Socket connection callback: 1 (0)
ssh_socket_unbuffered_write: Enabling POLLOUT for socket
callback_receive_banner: Received banner: SSH-2.0-Cisco-1.25
ssh_client_connection_callback: SSH server banner: SSH-2.0-Cisco-1.25
ssh_analyze_banner: Analyzing banner: SSH-2.0-Cisco-1.25


and then stucks with:

Error: Unable to establish the connection. Please make sure your connection settings are valid.

Clock2 yrs

Hi Max,

Thanks for the information.

The SSH Shell session does not support opening via an external client. The deprecated SSH Shell (native) did though. This would open a Terminal.app window and feed it with the relevant command and parameters. You'd than have to set the Display mode to external:

SSHShellNative

External

I'll look into porting the external mode behavior from the deprecated session to the newest one.

If you'd like to use an external client of your choosing and if it supports command line or has AppleScript integration, you can always use the Command Line session to launch any app.

Best regards,

Xavier Fortin

signaturesignature

SSHShellNative.png
External.png
Clock2 yrs

Hi Xavier,

thank you for this superfast response. Do you have a idea why/when it will be fixed in rdm ? I can provide any logs if you need !

Kind regards,
max

Clock2 yrs

Without being able to reproduce it on our side, this risk being a bit hard to fix. So many different SSH servers bring so many different behaviors that often slip by us.

I don't know if this is possible for you. But most of the time getting access to a faulty server allow us to fix it quite faster (if you have an isolated test switch that you wouldn't mind temporarily providing access to).

In the mean time, I'll push the information you've already provided to the dev in charge of our SSH Terminal and see what he has to say.

Your log that you provided, did you get them with the Verbose mode set to 4? If not, could you do it again with Verbose set to 4 and send me the terminal output afterwards via private message.

Verbose4

Best regards,

Xavier Fortin

signaturesignature

Verbose4.png
Clock2 yrs

Hi Xavier,

thank you again for the fast response! Yes it was set to verbose lvl4, unfortunately i can not provide you access through the internet to one of our switches. But i can provide a teamviewer session if it could help.
I see that the connection toe the switch only work the on first attempt but with a wrong message (switch was not in rdm before!):

Eventually i can disable this key store feature somewhere ?

Bildschirmfoto 2018-01-16 um 17.12.34.png
Clock2 yrs

Hi Max,

I've forwarded this issue to the SSH Terminal team. They're looking into other issues with Cisco switch. I'll get back to you with any news.

I'm not sure I understood your last inquiry.

The image you've attached is the message shown when RDM does not find the right host/key pair already registered on the system and ask you to confirm the identity of the server you're attempting to connect to. If you only click on resume it'll start the session without remembering the server while Resume and Remember Server will remember it on subsequent connect attempt.

You can find the remembered hosts in the known_hosts file (~/.ssh/known_hosts).

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

Hi Xavier,

the message in the screenshot appears right in the moment i was try to connect to a new switch. The message seems to tell me that rdm already got a fingerprint for that switch, but this is impossible because the switch was totally new.

Kind regards,
Max

Clock2 yrs

Hi Max,

The message is a bit misleading. Even though it says "Remote Host Identification Has Changed", it will also be shown when you first connect to a server. Meaning that this server has never been remembered by your computer. You can just click Resume and Remember Server and this will save the server in your known_hosts and won't bother you again with this window.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

I also have this issue both at work and at home. I could temporarily open a port forward, provide an openVPN session or join a webex/skype/goto/teamview/name-your-poison session to get you access for testing. I have the option "always accept fingerprints" enabled. I am able to use deprecated SSH (native) both external and embedded but I lose after login commands options and automatic "enter" after connection by doing so.

Clock2 yrs

Hi,

When you say you have the same issue, you're referring to connecting to a Cisco Catalyst switch? If so, the access would be greatly appreciated. You can send me everything required and the instructions directly to my email: xfortin@devolutions.net.

I'll try to reproduce the issue on my side and, if I reproduce it, I'll have to forward those access to the dev working on the SSH Terminal component of RDM. Is that alright with you?

One thing you said somewhat surprise me. SSH Shell (native) embedded works for you? Both the SSH Shell and SSH Shell (native) use the same component within if they are launched in embedded mode. If SSH Shell (native) embedded works for you, I'd wager this is a configuration issue that must be the problem in your SSH Shell session.

Before trying anything else (even before considering us testing directly on one of your server), could you create two sessions, one using SSH Shell and the other using SSH Shell (native) that connect to the same server (one of the server you're having difficulty with), confirm that it works with SSH Shell (native) and not SSH Shell (both in embedded mode), export them (you can open them with a text editor and remove all tags holding passwords, I won't need credentials) and send them to me to the address I've mentioned earlier. I'll see how the terminal control is set differently between those. Hopefully, I'll found what settings is guilty that way.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs