Forum / Remote Desktop Manager Mac - Support

Webbrowser automatic login not working (none of the browsers)

  • Create an Issue
  • Cancel

Hi,
I'm having issues automatic login of web pages using RDM 4.2.1.0. I setup the Web browser session and tried different browsers and none of them work.

My situation and problems:

1) Using Safari 10.0.3 and the extension (4.0.0.0), when I click at the Devonlink extension at browser, it shows "Checking Status" and does not do anything after that. Do I need to change any of the default settings at extension or somewhere else?

2) Using Firefox, I do have the latest extension (add-on) installed, but at the RDM is tells me that the browser extension is not installed at RDM.

3) With OPERA is does not work also. When I click to open the browser, it opens the SAFARI browser. I do have Opera 43.0.2442.1165 installed and the Extension is also installed and showing.

4) Using Chrome and extension 4.0.8.0. Here something appears to work better, but I didn't manage to get it working.
a) I have saved the login details at the Login > Credentials tab.
b) After some time, I do see the Devonlink icon appearing next to user/password, but when I click it shows me "no credentials found for this website".
Questions:
1) Why RDM does not allow me to fill manually the Html Control ID fields?
2) I have saved the credentials, but it always shows me "no logins available"
What could be missing?
3) I tried to make a test using a external webpage and tried to test the fill of USER at the hotmail.com (https://login.live.com/login.srf). Now when I press CONNECT, the icon appears inside the text field and I'm not able to click at the icon.
4) Should RDM connect automatically or do I always have to click at the icon from RDM at the toolbar to connect?

Thx

Clock3 yrs

Hi,

For all the web browser extensions, in your web session do you have checked "Enable web browser extension link" checkbox?

Can you also check that the port you use to communicate with the browser extension and RDM is the same.

1) I will try to reproduce your issue with Safari.

2) Do you use the default the profile in Firefox? RDM is looking at the default location to know if the extension is installed.

3) I have been able to reproduce your issue. I will enter a bug report.

4.1) Change your display to embedded. I agree that it should allow it.

4.2) In your web session, do you have checked "Enable web browser extension link" checkbox?

4.3) I have been able to reproduce your issue. I will enter a bug report.

4.4) No, you need to connect each time you change your data source in RDM. It's already in our TODO list to automatically connect RDM with the browser extension.

Best regards,

Olivier Désalliers

signaturesignature

Screen Shot 2017-03-27 at 9.26.15 AM.png
Clock3 yrs