Forum / Remote Desktop Manager - Feature Request

Smooth/silent/fully-automatic RDP reconnect on server reboot

  • Create an Issue
  • Cancel

I have tested a lot of RDP connection managers recently and RDM seems the best one. The only feature I am missing from Terminals app - smooth RDP reconnect on server reboot (Win 2008r2 servers).

I have tried every option RDM 12.0.8 offers - smart reconnect, full reconnect, keep tab, reconnect when available, port scan then connect, ping then connect. Every time it takes me several clicks to dismiss RDP connection error messages, click again and so on.

What happens with Terminals application - when I click "Reconnect when ready" - it will silently try to reconnect fully until either successful reconnect or program is closed.

Clock2 yrs

Hello,

The Keep tab opened on disconnect is one option that you mentioned that will allow you to reconnect automatically when it comes back online;
https://help.remotedesktopmanager.com/index.html?tipsandtricks_keeptabsopened.htm

By the way, we have an option in File -> Options -> Types -> RDP to dismiss RDP connection error messages. It is called "Disable embedded RDP error message" Please enable this option.

image

Best regards,



Mark Beausejour

signaturesignature

Customers that use Devolutions Password Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

Clock2 yrs

It does not work as expected. RDM pings/scans _rebooting_ server. Then it tries to connect. As server is rebooting (either shutting down or just loading up) at some point connect happens but does not completely go through. After 1st try RDM gives up reconnecting. That is it.

Look here: https://www.dropbox.com/s/xaal1op7s6xs3db/RDM%20reconnect.mp4?dl=0

Clock2 yrs

Could you post a small video of the workflow in Terminal? I think we don't do it the same way.

Regards

David Hervieux

signaturesignature

Clock2 yrs

Here goes Terminals app reconnect: https://www.dropbox.com/s/swdw88s2dpsd4p8/Terminals_reconnect.mp4?dl=0

PS: terminals app - https://chocolatey.org/packages/terminals

Clock2 yrs

Thats what's RDM should do. Could you change the ping online method to Port scan and check if it works?

Regards

David Hervieux

signaturesignature

Clock2 yrs

It was set to port scan. When set to ping it does indeed produces much more false connects. Complete connection settings for the video above: https://www.dropbox.com/sh/cwzvz72k8x9ecf2/AACkDvmg8QTwNXwtfwWkiPXaa?dl=0

Clock2 yrs

I will enter a feature request and verify

Regards

David Hervieux

signaturesignature

Clock2 yrs

Hello,

We investigated and it seems to be a timing issue with the reconnect going too fast. A fix has been made internally and it will be available in the next build of RDM. When it's out, could you try it out and give us some feedback? Thank you.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs