Forum / Remote Desktop Manager Mac - Bug Report

Some bugs for RDM for MAC

  • Create an Issue
  • Cancel

Xavier Fortin wrote:

Hi,

First of all, sorry for any inconveniences. We're always trying to offer the best reliability, but we're working with a huge code base and sometime, issues pass through testing. The offline mode in particular is a very large feature that encompasses multiple parts of the application.

I can understand your difficulties, but I'm experiencing problems with the offline feature from a long time. You have to understand that if that feature doesn't work, you can't work anymore. If the app crashes and you can restart and continue to work it's annoying, but you can work. If the application crashes and and when it starts again it gives an error on the offline cache (like in the version before) or it clears the cache completely (like in this version)
YOU
CAN'T
WORK
ANYMORE
If I look at the change log of the application you're adding more and more feature every time, why instead not fixing the feature you have already entered? Am I the only one that uses the offline feature? Or am I the only one that has problems? It has to be fixed, otherwise this app is completely useless. And please note that given the bug list that I already posted it seems that nobody ever really tested the application (take a look at the bug I posted and please don't tell me that no one ever tryed to open more than 3 rdp sessions and then log-off from one of them....).

Xavier Fortin wrote:


That being said, I'm not able to reproduce your issue. You said it was hanging with the spinning wheel? Could you describe what you were doing before the spinning wheel? Did it seem random, or was it after a specific action? How long would you say it hanged before you forced quit?

No sessions opened, I clied on "check for updates", spinning wheel, crash, force quit, entry list empty.

This bug is also not yet fixed:
If it can be helpful for you, I have an update. Let's suppose you have four rdp sessions opened, session1, session2, session3 and session4, and you log out from session2:
Scenario1: you logout from session2, you wait for the terminal session to close, and you go to session1 ---> no problems.
Scenaroi2: you logout from session2, you immediately switch the focus to session1 (before remote session2 completes the logoff process) ---> as soon as session2 closes, session1 gets blank, session 3 and 4 are ok. I've tried many times, and just the active session gets blank.

Clock3 yrs

Hi again,

Once again, I understand your frustration. We'll do our best to figure this out. Just to make sure, your application started hanging right after you hit the Check for update? No window was shown?

I've been trying to reproduce the clearing of the cache by force quitting the app while in offline mode, or freezing the app, or crashing the app and so far, no issue.

Are you using the MCDF v2.0 offline mode? You can see this in the Preferences at Advanced -> Advanced -> Offline Engine.

Is there an offline.<something> in the datasource settings folder: /Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager/<data source id>?

As for the RDP bug. You're not disconnecting your session, right? You use the Log Off menu item? If so, I would appreciate it if you could provide me with a video of you reproducing the issue. So far I'm not able to reproduce this. I hit Log Off, Click on Yes and switch as fast as humanly possible to another tab and I get no white screen. I might be missing something.

A couple of pieces of information might help me.

What's the session RDP Engine (Session settings -> Microsoft Remote Desktop (RDP) -> General -> RDP Engine) and the default RDP Engine (Preferences -> Session Type -> RDP -> RDP Engine)?

Is your session running in Sandbox (Session settings -> Microsoft Remote Desktop (RDP) -> Advanced -> Activate Sandboxing and Preferences -> Session Type -> RDP -> Activate Sandboxing)?

Are you using OpenGL (Session settings -> Microsoft Remote Desktop (RDP) -> Advanced -> Use OpenGL and Preferences -> Session Type -> RDP -> Use OpenGL)? OpenGL in particular might help with this.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Xavier Fortin wrote:

Hi again,
Once again, I understand your frustration. We'll do our best to figure this out. Just to make sure, your application started hanging right after you hit the Check for update? No window was shown?

exactly.

Xavier Fortin wrote:


I've been trying to reproduce the clearing of the cache by force quitting the app while in offline mode, or freezing the app, or crashing the app and so far, no issue.

is there any log file? is there a way to raise the log level?

Xavier Fortin wrote:


Are you using the MCDF v2.0 offline mode? You can see this in the Preferences at Advanced -> Advanced -> Offline Engine.

it was on default now I changed it to mdcf v2.

Xavier Fortin wrote:


Is there an offline.<something> in the datasource settings folder: /Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager/<data source id>?

***:b4248f3e-5295-4a2b-b691-92ab7392131a ***$ ls -lah
total 7072
drwxr-xr-x 5 *** staff 170B Jun 1 07:10 .
drwxr-xr-x 19 *** staff 646B May 31 16:50 ..
drwxr-xr-x 2 *** staff 68B May 31 19:05 PlayList
-rw-r--r-- 1 *** staff 2.9M May 6 16:09 offline.db
-rw-r--r-- 1 *** staff 540K Jun 1 07:13 offline.mcdf2
***:b4248f3e-5295-4a2b-b691-92ab7392131a ***$

I don't remember their size before reconnecting rdm to my data source.

Xavier Fortin wrote:


A couple of pieces of information might help me.
1-What's the session RDP Engine (Session settings -> Microsoft Remote Desktop (RDP) -> General -> RDP Engine) and the default RDP Engine (Preferences -> Session Type -> RDP -> RDP Engine)?
2- Is your session running in Sandbox (Session settings -> Microsoft Remote Desktop (RDP) -> Advanced -> Activate Sandboxing and Preferences -> Session Type -> RDP -> Activate Sandboxing)?
3- Are you using OpenGL (Session settings -> Microsoft Remote Desktop (RDP) -> Advanced -> Use OpenGL and Preferences -> Session Type -> RDP -> Use OpenGL)? OpenGL in particular might help with this.

1-while I was checking that setting, i selected an entry (a random one, the problem is present in all of my 1300 entries...), right click, edit, boom, all entries disappear (I was offline), i switched to online (no entries), i switched back offline (no entries). I checked my server, everything ok. I had to delete my data source and create a new connection back again. Now all the entries are present (both online and offline).

I will come back to my windows pc. This application is not stable on mac. please buy a mac, hire some developer, and fix it.

Clock3 yrs