Forum / Remote Desktop Manager Mac - Bug Report

Some bugs for RDM for MAC

  • Create an Issue
  • Cancel

- I try to start RDM without connection to SQL database, my datasource does not switch to offline mode, and no entry are loaded.
The only way is to start it while connected to SQL server, and then go offline. But if I have to restart the computer, or quit and open again the application while I'm away from the office, there is no way to load any entry.

- When offline, if you try to create a new session, the new session is not displayed until you go back online, and offline again.

- Within an rdp session, "\" key is switched with "<" key on italian keyboard. All other special keys work correctly.

- Sometimes closing an rdp session makes another rdp session screen blank, the only way to get access again is to close and open it again, or click on "reconnect".

- On an rdp entry in the list, right click, "open with parameters", if you click on "prompt for credentials" you are prompted for credentials, but they are ignored by the terminal server (you have to insert them twice, once in RDM and once in remote RDP session).

RDM for MAC Enterprise Edition 4.0.1.1482504117 running on Mac OS Sierra 10.12.1

Many thanks in advance.

Clock3 yrs

Updated topic with a new bug.

Clock3 yrs

Hi,

I try to start RDM without connection to SQL database, my datasource does not switch to offline mode, and no entry are loaded.
The only way is to start it while connected to SQL server, and then go offline. But if I have to restart the computer, or quit and open again the application while I'm away from the office, there is no way to load any entry.

I seem unable to reproduce this issue. When I try to connect to the SQL Server and either the network is down or my server host unreachable, I get prompted with the following window offering me to go offline:
GoOffline

Maybe you could send me your application log after reproducing the issue so I can check if there is something else causing the issue.

When offline, if you try to create a new session, the new session is not displayed until you go back online, and offline again.

I think it should have been fixed in the beta version I previously sent you, or am I wrong? Is this a different issue?

Within an rdp session, "\" key is switched with "<" key on italian keyboard. All other special keys work correctly.

I seem unable to reproduce this behavior. I've added the Italian (Italy) keyboard in my remote machine and tried the key I think you're referring to and they seem to write what's expected. I'm not familiar with the Italian keyboard though. Are you referring to those keys:
ItalianKeyboard

Sometimes closing an rdp session makes another rdp session screen blank, the only way to get access again is to close and open it again, or click on "reconnect".

I'll have to investigate this further, but I'll inform you as soon as there is any progress.

On an rdp entry in the list, right click, "open with parameters", if you click on "prompt for credentials" you are prompted for credentials, but they are ignored by the terminal server (you have to insert them twice, once in RDM and once in remote RDP session).

I reproduce the issue. I've removed the first prompt since I didn't see the purpose of it in the Mac version of the application. Just tell me if it cause any other issue when you get to try the next version.

Best regards,

Xavier Fortin

signaturesignature

GoOffline.png
ItalianKeyboard.png
Clock3 yrs

Xavier Fortin wrote:

Hi,

I seem unable to reproduce this issue. When I try to connect to the SQL Server and either the network is down or my server host unreachable, I get prompted with the following window offering me to go offline:
image

Maybe you could send me your application log after reproducing the issue so I can check if there is something else causing the issue.

Hi Xavier, if you send me instructions on how to create the log you want I will be glad to send you it.
I'm not sure if the problem exist if you're not connected to the network, I'm always connected to a network.
But I'm sure the problem exist if the server is not reachable.

Xavier Fortin wrote:

I think it should have been fixed in the beta version I previously sent you, or am I wrong? Is this a different issue?

No, it's a different issue. The issue you fixed in the beta was about modifying an existing entry (if you tried to edit an entry, it was not edited while offline), and the problem is fixed.
The problem I'm having now is that if you try to create a new entry, it is not displayed until you go online, and come back offline.

Xavier Fortin wrote:


I seem unable to reproduce this behavior. I've added the Italian (Italy) keyboard in my remote machine and tried the key I think you're referring to and they seem to write what's expected. I'm not familiar with the Italian keyboard though. Are you referring to those keys:
image

The keymap of the picture is correct, and you perfectly understood which keys are "swapping" smile
in an rdp session, if you type the "<" key of your picture you get the "\" key, and viceversa. All the other keys are working.

Xavier Fortin wrote:

I'll have to investigate this further, but I'll inform you as soon as there is any progress.

If it can be helpful for you, I have an update. Let's suppose you have four rdp sessions opened, session1, session2, session3 and session4, and you log out from session2:
Scenario1: you logout from session2, you wait for the terminal session to close, and you go to session1 ---> no problems.
Scenaroi2: you logout from session2, you immediately switch the focus to session1 (before remote session2 completes the logoff process) ---> as soon as session2 closes, session1 gets blank, session 3 and 4 are ok. I've tried many times, and just the active session gets blank.

Xavier Fortin wrote:

I reproduce the issue. I've removed the first prompt since I didn't see the purpose of it in the Mac version of the application. Just tell me if it cause any other issue when you get to try the next version.

Wait! I think that the purpose of the first prompt is for rdp session with NLA authentication (SSO), please check if it works with NLA TS before removing it completely from RDM!

Xavier Fortin wrote:

Best regards,

Thank you very much for your help Xavier!

Clock3 yrs

Hi,

You can find your application log under Help -> View Application Log. You can copy the content of the window with the Copy button and send it to me via private message.

No, it's a different issue. The issue you fixed in the beta was about modifying an existing entry (if you tried to edit an entry, it was not edited while offline), and the problem is fixed.
The problem I'm having now is that if you try to create a new entry, it is not displayed until you go online, and come back offline.

That's the weird thing. You see, the issue was that between two versions of RDM, a part of the code that was responsible to ensure the displayed connection tree was up to date was broken. This happen after each modification (be it editing or adding a connection), which is why it should be fixed in this version too. I'm testing right now, and in my case, it does update. Are you having the same issue when deleting an entry?

I might find something in your log. Remind me again, are you using an SQL Server datasource?

The keymap of the picture is correct, and you perfectly understood which keys are "swapping" image
in an rdp session, if you type the "<" key of your picture you get the "\" key, and viceversa. All the other keys are working.

I think I found the issue and it lies within the keyboard layouts offered by the operating systems themselves. The Itialian (Italy) keyboard in Mac as the top left key be "<" (and therefor has the key beside the right Shift key be "\"). The Italian keyboard Windows offer does the opposite (Go figure). Since an RDP session uses the layout on the remote machine side, there is few things we can do. Maybe installing a custom keyboard layout on the remote host.

Wait! I think that the purpose of the first prompt is for rdp session with NLA authentication (SSO), please check if it works with NLA TS before removing it completely from RDM!

The thing is, we work slightly different than Windows here. Since they use the DirectX component for their RDP implementation, it seems to handle the login prompt. In mac, we handle it directly. What did you mean, that this prompt would be required for RDP session requiring NLA or those that don't?

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Xavier Fortin wrote:

Hi,

You can find your application log under Help -> View Application Log. You can copy the content of the window with the Copy button and send it to me via private message.

Ok I'll try and get back to you.

Xavier Fortin wrote:


That's the weird thing. You see, the issue was that between two versions of RDM, a part of the code that was responsible to ensure the displayed connection tree was up to date was broken. This happen after each modification (be it editing or adding a connection), which is why it should be fixed in this version too. I'm testing right now, and in my case, it does update. Are you having the same issue when deleting an entry?

I rarely delete an entry, but I will try!

Xavier Fortin wrote:


I might find something in your log. Remind me again, are you using an SQL Server datasource?

Yes, Microsoft SQL server express as datasource.

Xavier Fortin wrote:


I think I found the issue and it lies within the keyboard layouts offered by the operating systems themselves. The Itialian (Italy) keyboard in Mac as the top left key be "<" (and therefor has the key beside the right Shift key be "\"). The Italian keyboard Windows offer does the opposite (Go figure). Since an RDP session uses the layout on the remote machine side, there is few things we can do. Maybe installing a custom keyboard layout on the remote host.

The italian keyboard layout of my 2015 macbook pro is exactly the same of your picture (I just checked), and in MAC Os everything is ok, but within a RDM RDP session \ and < are swapped.

Xavier Fortin wrote:


The thing is, we work slightly different than Windows here. Since they use the DirectX component for their RDP implementation, it seems to handle the login prompt. In mac, we handle it directly. What did you mean, that this prompt would be required for RDP session requiring NLA or those that don't?

Best regards,

I mean that I don't know if that prompt is required when connecting to a NLA TS Server, I was just asking you to try, after you remove that prompt from the code, to check if everything works correctly with bot a classic TS and an NLA TS.

Thank you again tomorrow I will try again with offline and let you know!

Clock3 yrs

JB81 wrote:


When offline, if you try to create a new session, the new session is not displayed until you go back online, and offline again.

Xavier Fortin wrote:


That's the weird thing. You see, the issue was that between two versions of RDM, a part of the code that was responsible to ensure the displayed connection tree was up to date was broken. This happen after each modification (be it editing or adding a connection), which is why it should be fixed in this version too. I'm testing right now, and in my case, it does update. Are you having the same issue when deleting an entry?

I might find something in your log. Remind me again, are you using an SQL Server datasource?

Hi Xavier, I had some time to test this problem:
Step1: Delete an entry: the problem does not happen, the entry is immediately removed from the view.
Step2: Add an entry: the problem does not happen, the entry is immediately added to the view.
Step3: Duplicate an entry: you choose to duplicate, you enter the name of the new entry, you change something (e.g. the ip address), you press ok. Here is the problem: the entry is not added to the view.
- If you go online and go back offline, the new entry (step3) is added to the view.
- Here is the funny part: if you duplicate an entry (step3) it is not added to the view, but if you add (step2) or delete (step1) an entry, the view is updated and the duplicate entry (step3) is added to the view without the need to go online and come back offline.

Clock3 yrs

Hi,

The italian keyboard layout of my 2015 macbook pro is exactly the same of your picture (I just checked), and in MAC Os everything is ok, but within a RDM RDP session \ and < are swapped.

I do believe you, but the only thing I can conclude is that the Mac Italian keyboard layout and the Windows treat the key code corresponding to this key differently. So even if is is placed correctly on the keyboard, what is actually taken into account is this:
ItalianKeyboardLayout

While the Windows layout is as shown in the previous picture. Are you using an external keyboard, or is it on a laptop?

I think that, even if your "\" key is at the top left as in a Windows keyboard, it is still sending the key code of the "<" key (and vice versa). I have this behavior on both my external usb keyboard and my Macbook Pro keyboard. The same key code are simply associated with different characters in both OS.

We could probably fix it by inverting the key code sent, but I can't apply this as a general rule for all RDP session since it would break the keyboard of other user. I could add a checkbox to fix your particular issue though.

I mean that I don't know if that prompt is required when connecting to a NLA TS Server, I was just asking you to try, after you remove that prompt from the code, to check if everything works correctly with bot a classic TS and an NLA TS.

To be fair, this feature appears half implemented. I've just made sure the second prompt is not shown if the first one was already shown. It should work for all connection types and with the NLA option off in RDP session, too.

Hi Xavier, I had some time to test this problem:
Step1: Delete an entry: the problem does not happen, the entry is immediately removed from the view.
Step2: Add an entry: the problem does not happen, the entry is immediately added to the view.
Step3: Duplicate an entry: you choose to duplicate, you enter the name of the new entry, you change something (e.g. the ip address), you press ok. Here is the problem: the entry is not added to the view.
- If you go online and go back offline, the new entry (step3) is added to the view.
- Here is the funny part: if you duplicate an entry (step3) it is not added to the view, but if you add (step2) or delete (step1) an entry, the view is updated and the duplicate entry (step3) is added to the view without the need to go online and come back offline.

Thank you for the details. I've reproduce the issue and it is indeed tied to the duplicate. I'll fix it right away.

Best regards,

Xavier Fortin

signaturesignature

ItalianKeyboardLayout.png
Clock3 yrs

Xavier Fortin wrote:


I seem unable to reproduce this issue. When I try to connect to the SQL Server and either the network is down or my server host unreachable, I get prompted with the following window offering me to go offline:
image

Maybe you could send me your application log after reproducing the issue so I can check if there is something else causing the issue.

Hi Xavier, unfortunately I cannot send you any log, because application hangs (spinning wheel) and I have to force quit RDM.
The only way to start RDM again is to open a vpn connection to office and then open RDM.
Here are the screens if I try to open RDM without a connection to SQL server:

image

image

image

Clock3 yrs

This is weird. You say you were able to go in Offline Mode with the ribbon button?

Just in case could you make sure the offline mode is correctly enabled? To do so make sure that the Offline mode is set to Read only or Read/write in the datasource configuration:
DataSourceConfiguration

This should be the only one that matter in this case if you already have an offline cache since the next step are server side, but still, if you can connect online set to Read only or Read/write the Offline mode in the data source settings:
DataSourceSettings

Do so also in the User settings with which you attempt to connect:
User

Best regards,

Xavier Fortin

signaturesignature

DataSourceConfiguration.png
DataSourceSettings.png
User.png
Clock3 yrs

Hi Xavier, I have exactly those settings in RDM for MAC.

I have to go offline before losing the connection to the sql server, otherwise I cannot open RDM.

Clock3 yrs

The only other reason I can think of for the Go Offline button to be hidden is if the offline.db file was absent for some reason.

Could you check it out. For this, you need to go to the RDM configuration folder:
/Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager

Just replace <User> in this path with your Mac user.

Then, you will need the ID of your data source. You can find it at the bottom of the data source configuration view:
DataSourceID

You should find a folder with this ID as it's name (there might be two, ignore the one ending with \). In it should be the offline.db file mentioned. If it is not there, this is the issue.

Best regards,

Xavier Fortin

signaturesignature

DataSourceID.png
Clock3 yrs

Hi Xavier, my datasource ID starts with B42xxxxxxx
I have a folder that starts with B42xxx and ends with \ and there is no offline.db in that folder.
Then I have a folder that starts with b42xxx (please note that "b" is not capital), and there I have offline.db

Clock3 yrs

I'm surprised it is not capitalized, though I don't think it matters. Could you try deleting it and restarting RDM (with access to your datasource). It should recreate the folder (and also the Offline.db). Tell me if the created folder is in capital letter and try opening RDM (without access to you datasource) to see if the offline mode now works.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi Xavier, I tried to configure the datasource from scratch, no changes, same problem.

Clock3 yrs

Hi,

I'm still struggling to reproduce your issue.

Could you send us your Data Source Information? It is under File -> My Data Source Information (you must not be offline). At the bottom of the embedded view, there will be a button with an envelope. Click on it to send your data source information to the Support. In the message, tell them to forward me the email.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi Xavier, I sent the information to support.

Bye.

Clock3 yrs

Hi,

Everything seems normal in the file you've sent me. It even finds the Offline file and gets it size.

We're in the process of releasing a new version, so I can't do it now, but later on this week, I will build a beta version with additional log surrounding your specific issue to try to pinpoint what specifically make the Go Offline button hidden.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi,

A user contacted us with an issue with the offline mode slightly similar to yours. I'm still investigating, but having your application log would help.

Hi Xavier, unfortunately I cannot send you any log, because application hangs (spinning wheel) and I have to force quit RDM.

If you can't get your application log through the app, you can always get the file directly. Here is the path:
/Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager/RemoteDesktopManager.log

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi Xavier, I recreated the problem (today at 16:30) and copied the log file to my desktop.
If you give me your email address I can send you the log file.
Anyway I think this is the relevant part:

[1/30/2017 4:30:26 PM]INFO select DatabaseVersion from DatabaseInfo;
[1/30/2017 4:30:26 PM]INFO Reindex DatabaseInfo...done
Reindex Properties...done
Reindex Connections...done
Vacuum...done

[1/30/2017 4:30:26 PM]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/xxxxxxxxxxxxxx/Library/Application Support/com.devolutions.remotedesktopmanager/091cfd3a-f025-40d5-9d18-d2cd225a63fd/offline.db
[1/30/2017 4:30:26 PM]INFO ClearCache - Offline file has been deleted, recreating new file
[1/30/2017 4:30:26 PM]INFO ALTER TABLE DatabaseInfo add Expiration datetime;
[1/30/2017 4:30:26 PM]INFO
PRAGMA integrity_check...done

[1/30/2017 4:30:26 PM]INFO Reindex DatabaseInfo...done
Reindex Properties...done
Reindex Connections...done
Vacuum...done

[1/30/2017 4:30:26 PM]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/xxxxxxxxxxxxxx/Library/Application Support/com.devolutions.remotedesktopmanager/091cfd3a-f025-40d5-9d18-d2cd225a63fd/offline.db
[1/30/2017 4:30:26 PM]INFO ClearCache - Offline file has been deleted, recreating new file
[1/30/2017 4:30:26 PM]INFO ALTER TABLE Connections add OfflineAction varchar NULL;
[1/30/2017 4:30:26 PM]INFO
PRAGMA integrity_check...done

[1/30/2017 4:30:26 PM]INFO Reindex DatabaseInfo...done
Reindex Properties...done
Reindex Connections...done
Vacuum...done

[1/30/2017 4:30:26 PM]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/xxxxxxxxxxxxxx/Library/Application Support/com.devolutions.remotedesktopmanager/091cfd3a-f025-40d5-9d18-d2cd225a63fd/offline.db
[1/30/2017 4:30:27 PM]INFO ClearCache - Offline file has been deleted, recreating new file
[1/30/2017 4:30:27 PM]INFO create index IX_Connections_OfflineAction on Connections(OfflineAction);
[1/30/2017 4:30:27 PM]INFO
PRAGMA integrity_check...done

[1/30/2017 4:30:27 PM]INFO Reindex DatabaseInfo...done
Reindex Properties...done
Reindex Connections...done
Vacuum...done

[1/30/2017 4:30:27 PM]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/xxxxxxxxxxxxxx/Library/Application Support/com.devolutions.remotedesktopmanager/091cfd3a-f025-40d5-9d18-d2cd225a63fd/offline.db
[1/30/2017 4:30:27 PM]INFO ClearCache - Offline file has been deleted, recreating new file
[1/30/2017 4:30:27 PM]INFO ALTER TABLE DatabaseInfo add Settings varchar NULL;
[1/30/2017 4:30:27 PM]INFO
PRAGMA integrity_check...done

[1/30/2017 4:30:27 PM]INFO Reindex DatabaseInfo...done
Reindex Properties...done
Reindex Connections...done
Vacuum...done

[1/30/2017 4:30:27 PM]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/xxxxxxxxxxxxxx/Library/Application Support/com.devolutions.remotedesktopmanager/091cfd3a-f025-40d5-9d18-d2cd225a63fd/offline.db
[1/30/2017 4:30:27 PM]INFO ClearCache - Offline file has been deleted, recreating new file
[1/30/2017 4:30:27 PM]INFO ALTER TABLE Connections add OriginalData TEXT NULL;
[1/30/2017 4:30:27 PM]INFO
PRAGMA integrity_check...done

[1/30/2017 4:30:27 PM]INFO Reindex DatabaseInfo...done
Reindex Properties...done
Reindex Connections...done
Vacuum...done

[1/30/2017 4:30:27 PM]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/xxxxxxxxxxxxxx/Library/Application Support/com.devolutions.remotedesktopmanager/091cfd3a-f025-40d5-9d18-d2cd225a63fd/offline.db
[1/30/2017 4:30:28 PM]INFO ClearCache - Offline file has been deleted, recreating new file
[1/30/2017 4:30:43 PM - 4.0.1.1482504117]ERROR System.Data.SqlClient.SqlException (0x80131904): Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
at System.Data.SqlClient.SqlConnection.Open () [0x00162] in <a566c189d19d4271ab58420d6f875b13>:0
at A.c1b7e8caf3fa8e5fb77cc57c00e8d5e1c.cf7143f4d0ccb8590178f208ae12c1b10 (System.String c0543ca550f15febd1b069e16fd4b95e1, System.Data.IDbDataParameter[] c91084b2aae54f62d01e2a4664a847bd7) [0x0001d] in <ef01d1cea6bf414baa02a08419121359>:0
at Devolutions.RemoteDesktopManager.Business.DataSources.SQLServerConnectionDataSource.c1e3e098748c6efd7f005032d264f60b2 () [0x00070] in <ef01d1cea6bf414baa02a08419121359>:0
at A.cbbb560bfd0154564f3a0626f8038689f.cca44e7b409894de57ef01c51d223624f (A.c323b374042cd3040715f1835f9a00a5c c575f8eb13de2147c285404f8805d1720) [0x000e7] in <ef01d1cea6bf414baa02a08419121359>:0
****************************** SqlError ******************************
Message:Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
Procedure:Open()

Clock3 yrs

Indeed, this is what I wanted to see. For some reasons, the offline mode is always malformed (I will assume created malformed).

I still don't know why, but at least it gives me something to look at.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi,

I've went and spoke with the person who implemented the offline mode (in Windows) and they also add user experiencing similar issue with corrupted SQLite files. They added the MCDF and MCDFv2 offline mode engine to avoid this problem.

In the next version of RDM Mac, which should hopefully be release soon, you'll be able to set the offline engine to MCDFv2, which might resolve your issue.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi Xavier, do you know when will it be released? Without offline mode working it is not so much useful for me.

Thanks.

Clock3 yrs

The version is currently going through QA. If everything is going well, you should be able to download it early next week.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

great

Clock3 yrs

The new version of RDM (4.1.0.0) is now out.

You can change the Offline engine in the Preferences under Advanced -> Advanced. Try setting it to MCDFv2 and tell me if it works now. You will need to connect online first, so RDM can create the new offline cache.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi Xavier, I just updated rdm to version 4.1 but unfortunately I can't connect to my sql server till tomorrow. I will let you know!!!

Thanks again!

Clock3 yrs

Hi,

The version 4.2.0.0 is out and it contains a new feature that could resolve your issue with the swapped key on the Italian layout.

With RDM 4.2.0.0, we've introduced the Shortcuts Mapping for RDP sessions. You can access those in RDM preferences under Session Type -> RDP -> Shortcuts. Just use the "+" button to add a new mapping:
RDPShortcuts

You can just press the key that will be pressed and what you want it to send in the two text fields. Be aware that you'll have to do it for each modifiers too (probably shift and alt in this case):
RDPSetShortcut

In my first picture, you see this set to the two keys we've been talking about.

Tell me if you find any issues.

Best regards,

Xavier Fortin

signaturesignature

RDPSetShortcut.png
RDPShortcuts.png
Clock3 yrs

Hi Xavier, sorry if I did not post for long time but I switched back to my windows computer. RDM on MAC was not usable.
Now I took back my macbook pro to test the new version of RDM (4.3), but sadly it is not usable on a production machine, it is like a beta.
Today it crashed (coloured spinning wheel), I had to force quit and when it started again my datasource (SQL with offline) was completely empty.
Now I can't get my job done and I don't know what will happen when it will connect back to sql database (will it wipe it?).
To be honest, it is not possible to release a software with such problems and ask money for that. It can have missing features, but it cannot stop you from working in the middle of the day!!!

Attached you can find screenshot of my datasource set-up, please tell me what's wrong.

Screen Shot 2017-05-31 at 16.56.14.png
Screen Shot 2017-05-31 at 16.56.20.png
Screen Shot 2017-05-31 at 16.56.27.png
Screen Shot 2017-05-31 at 16.56.35.png
Screen Shot 2017-05-31 at 16.56.42.png
Screen Shot 2017-05-31 at 17.59.31-jpg.jpg
Clock3 yrs

Hi,

First of all, sorry for any inconveniences. We're always trying to offer the best reliability, but we're working with a huge code base and sometime, issues pass through testing. The offline mode in particular is a very large feature that encompasses multiple parts of the application.

That being said, I'm not able to reproduce your issue. You said it was hanging with the spinning wheel? Could you describe what you were doing before the spinning wheel? Did it seem random, or was it after a specific action? How long would you say it hanged before you forced quit?

Now I can't get my job done and I don't know what will happen when it will connect back to sql database (will it wipe it?).

I wouldn't worry about that. Though I understand the annoyance, this only seem to mean that the cache file has been cleared (for a reason that I would also like to find). When you get online it should simply recreate the cache with the online data, or at the very least it should ask confirmation from you before doing any modification to the live data.

Once again, sorry for any inconveniences.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs