Forum / Remote Desktop Manager - Feature Request

Select open tab using connection list in navigation panel

  • Create an Issue
  • Cancel

This used to work for me, but has stopped since going to the 11.9 beta.
Hasn't resolved in 12.0 or even if I rollback to 11.7
I am unable to select an opened connection using the list of connections in the left navigation panel. The only way I can select another opened connection is using the tabs at the top.

Clock2 yrs

Hello,

This has been fixed in RDM 12.0.2.0.

You can download it here;
https://remotedesktopmanager.com/Home/Download

Best regards,



Mark Beausejour

signaturesignature

Customers that use Devolutions Password Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

Clock2 yrs

I have just updated to 12.0.2.0 and it's still not changing tabs when I select from nagivation panel

Clock2 yrs

Hello,

Please go in File -> Options -> User Interface -> Tree View and check the option "Auto focus tab on item select.".
image

Best regards,



Mark Beausejour

signaturesignature

Customers that use Devolutions Password Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

Clock2 yrs

That option is also selected.
I tried deselecting and then selecting again but still no luck.

Clock2 yrs

Do you have the tab header visible?

Regards

David Hervieux

signaturesignature

Clock2 yrs

Is that in the properties of the connection - User Interface - Visibility?
that is set to Default


Also, I am having this same issue when I use 11.7.6 now

Clock2 yrs

I've seen in your previous post that you are using the Grouped Tab Header. Just for a test could you disable it?

It's the Tab Groups button in the View ribbon.

Regards

David Hervieux

signaturesignature

Clock2 yrs

I have now removed the tab group and still no difference

Clock2 yrs

I was reading your post again and I just wanted to be sure that we are talking of the same list. Do you mean the tree or the Opened connection nav section?

Regards

David Hervieux

signaturesignature

Clock2 yrs

I have attached an image.
The session selected in the left tree does not make it the active tab.


My colleague is using v12.0.0 and the same data course and he doesn't have this problem.
But it's also happening in v11.7.6 standalone.


How do I perform a complete uninstall? When I Use add/remove programs I can still run the standalone and it has all settings available so something isn't removed.

rdm-activetab.png
Clock2 yrs

Interesting...
I have found that when I uncheck the "Hide when connection successful" option in VPN settings, it will allow the tab to change when selecting the session in the tree. However it does make the SSH tunnel tab active rather than the RDP tab.


Other sessions that I don't use this VPN option are working fine and will change selection in the tree/tabs as expected


I guess this is what you are referring to where making tab header visible? But in a different method

rdm-activetab-vpn.png
rdm-activetab-vpn2.png
Clock2 yrs

It's interesting. I will ask Hubert to check this tomorrow.

Regards

David Hervieux

signaturesignature

Clock2 yrs

Hello,

We can reproduce the issue on our end, we'll see what we can do.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

The issue has been fixed internally and the change will be available in the next beta version of RDM 12 (12.0.4.0).

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

Hey guys,
After upgrading from 10.0.8.0 to 10.5.4.0 I am having this same issue as I logged above.
Something new since the upgrade is that when I open a new connection, it will auto show only that connections tab. I'm sure it used to default to the 'All' tab, while having the new tab unselected.
When I open multiple connections that are in different tabs, it doesn't change the active screen to the session I choose in the connections list in the left navigation window.
However, if I have multiple connections in the same tab, it does switch between the active sessions as expected.


I did try the previous workaround to "Hide when connection successful" however that didn't fix it this time.
I also checked File -> Options -> User Interface -> Tree View and check the option "Auto focus tab on item select." and that is already selected.
If I do use Tab Groups button, it works when I select the different machines in that window.

Clock2 yrs

Hello,

Could you try out the latest beta version 12.5.12.0? It should by default select the "All" tab group rather than the connection's which should help in your case. This also customizable in the options in the user interface tab under "tab group behavior". This option only came in a beta after 12.5.4.0 though.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

Thanks. This has got it back to how it used to work for me with the All tab being default.
Could it be a feature request to change active session when selecting the connection in navigation window, even if it's on a different tab?

Clock2 yrs

Hello,

We'll add this to our feature request list, thank you.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

I'd like this feature as well please

Clock2 yrs

Hello,

This feature has been added internally and should be available for use in the next beta of RDM.

We have also made group tabs remember the last embedded entry they had selected. This way when you switch between tabs it will put you back on the entry you were using instead of the Dashboard.

This option can be turned off in File -> Options -> User Interface -> Tab Bar -> Remember selection -> Change to "Legacy".

Regards,

Michaël Beaudin

signaturesignature

Clock10 mths