Forum / Remote Desktop Manager - Macro/Script/Tools

Issue with auto type macro

  • Create an Issue
  • Cancel

Hello guys, as always, thanks for such a great product, I'm facing an issue with the AutoType functionality in RDM. For some RDP sessions I have a credential (from the credentials repository) set in the session, still some systems will ask me to enter the credentials anyway (that's an OK behaviour because these systems are configured to require the user to manually input the credentials).

So I have these sessions set up to use the auto type Macro (under Events, After Connect), and the macro I'm using is: {Delay}$PASSWORD${Enter}

The issue I'm facing, is depending on the characters contained in the password, these might be replaced by something else, for instance it the password contains a "%", the macro will paste "[%]".

I've also tried to use the TOOLS_PASSWORD variable, by setting the credentials also in the Tools section, but the same happens with other set of characters, "<" will be replaced by "&lt" for example...

Could you please guys look into it? This macro is particularly useful.

Thanks!
Hernán

Clock3 yrs

Hello,

What version of RDM are you using?

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

Sorry, forgot to include that, I'm running RDM 11.7.6.0.
Thanks!
Hernán

Clock3 yrs

Hello,

We have been able to reproduce your issue.

The '%' character is replaced with '{%}' in the password. The password abc%123 will be typed as this abc{%}123.

A ticket has been submitted to our engineering department.

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

Thank you!

Clock3 yrs

Hello,

We will have a fix for this in the next build of RDM. When it is out could you test it and give us some feedback? Thank you.

Regards,

Hubert Mireault

signaturesignature

Clock3 yrs

For sure, want to reach out to me directly to my email address? Just for curious, do you have an ETA for the release?

Clock3 yrs

The tentative release date for RDM 12 is November 28th. We will try to update this topic when the new version is out.

Regards,

Hubert Mireault

signaturesignature

Clock3 yrs

Just tested the new version, the issue with the auto type macro and the $password$ variable has been resolved in this version! Thanks again guys!

Clock3 yrs