Forum / Remote Desktop Manager - Bug Report

11.7.2.0 breaks Sub Connections

  • Create an Issue
  • Cancel

Hi RDM Team,

I just gave 11.7.2.0 a try and for the first start it works without any problems. After closing RDM and restarting many sessions with sub connections don't have any sub connections anymore and icons are lost (see attached screenshots). If the cache path in AppData\Local\Devolutions\RemoteDesktopManager\ is deleted, RDM works fine for the next time. After closing and reopening RDM is broken again. We use RDM with a MySQL Datasource.

Do you have any idea where to look at? At the moment we stick with 11.6.5.0.

Kind regards

rdm_ok.png
rdm_notok.png
Clock3 yrs

Hello,

Could you please try to do a full refresh of your Data Source (CTRL+Refresh or CTRL+F5)?

If it doesn't help, could you please try to set the Caching mode to Disabled in the Data Source configuration?

image

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

Ok, so it seems Ctrl+F5 brings it back to life. Shortly after pressing Ctrl+F5, the missing sessions and icons show up. A normal F5 doesn't work.
So if I hit Ctrl+F5 once, then it seems fine, even for the following startups of RDM.

But if delete the local cache again and start up RDM, then all sessions are shown. After a second start the sessions are missing again. Opening and closing RDM several times doesn't help. But if I hit Ctrl+F5, all is back again and working beyond the next restarts.

Let me know if I can gather you some more infos...

Kind regards

Clock3 yrs

Hello,

Could you please go in Help -> Diagnostic and click on Send?

Thank you!


Best regards,



Mark Beausejour

signaturesignature

Clock3 yrs

Is it possible to send the diagnostic infos via mail? We have no internet connection on the machines with RDM running...

Clock3 yrs

Hello,

Certainly! Please include screenshots from Diagnostic and send them to support@devolutions.net


Best regards,



Mark Beausejour

signaturesignature

Clock3 yrs

Hello,

Could you please try to change the Offline engine to SQLite to see if it helps? Please go in File - Options - Advanced and set the Offline engine option to SQLite.

image

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

This helped indeed. And furthermore, the interface is now way more responsive for changing connection settings!

Clock3 yrs

Still seems good. Is it safe to let the Offline Engine at SQLite? Ok, and if it's safe, why isn't it default? wink

Clock3 yrs

Hi,
Yes it's safe to use it. It's used to be our default engine but some people had performance issues with it. That's why we have developed to other engine.

Regards

David Hervieux

signaturesignature

Clock3 yrs

Ok, so it seems like a bug in the new engine and surprisingly SQLite is noticeably faster in our case.
Thanks for the support, we will go ahead with the SQLite Engine

Kind regards

Clock3 yrs

The SQLite engine was giving us issues with some users where it would corrupt itself to the point where the file was completely unreadable. The only option was to delete it and start over. This was usually not an option since people were offsite and didn't have access to the data source hence the wanting to use the offline mode. The SQLite engine is written in C++ and all our testing we've never been able to reproduce the corruption therefore we are not able to fix the issue.

MCDF (Microsoft Compound Document Format) is a structured storage file format used by the old Office file format and .db (thumbnails) files. We have two engine versions, the major difference on both is file access, v2 does less file access (chunks them).

We keep all offline engines available for the simple reason is for this exact case where one engine doesn't work properly we can always fall back onto a different engine.

As for SQLite being faster, we will investigate. We've done some optimization for the MCDFv2 engine that might have also improved the performance of the SQLite engine.

Best regards,

Stefane Lavergne

signaturesignature

Clock3 yrs

Found the issue with the MCDFv2 offline engine, the fix will be in the next release.

Best regards,

Stefane Lavergne

signaturesignature

Clock3 yrs

Cool, thanks for the complete information and for fixing the bug!

Kind regards

Clock3 yrs