Forum / Remote Desktop Manager - Macro/Script/Tools

Auto-type macros on Mac?

  • Create an Issue
  • Cancel

Hi everybody,

is it a known issue that typing macros after connect does not work in the Mac version? Does a work-around exist or will this be fixed in the future?

Best regards,
Andreas

Clock3 yrs

Hi Andreas,

I"m not sure exactly what issue you are experiencing.
Would you mind being more specific about what you are trying to do?
What type of entry you are using (RDP, SSH, VNC, ...)?
Are trying to select an existing typing macro or are you building one inline?

Best regards

Benoît Sansregret

signaturesignature

Clock3 yrs

Hi Benoit,

oh sorry, you're right, that informations would have been helpful... It's an SSH connection and I try to automatically sign in as root, while the connection use another user for login. Unfortunately the macro isn't executed at all. While this works in the Windows version of RDM, it fails in the Mac version for all SSH connectons. RDM-Version is 3.5.4.2.
Reproduction: Edit an entry, go to events, after connect, Typing macro f.e. "su -{ENTER}{DELAY}$CUSTOM_FIELD1${ENTER}".

Best regards,
Andreas

Clock3 yrs

Hi Andreas,

Sorry, I wasn't able to reply to you yesterday.
Thank you for the additional information I will investigate your issue as soon as possible.

Best regards,

Benoît Sansregret

signaturesignature

Clock3 yrs

Hi Andreas,

I managed to make it work in my test environment.
One thing that was causing me trouble is the initial delay before the macro is launched.
I had to increase the value since there was a long delay between the connection and when the prompt is ready.
If the macro was launched too early it wouldn't work.
2016+08+05+09+07+09

Would you mind trying to increase that value and see what happens?
This delay should be as long as it takes to the prompt to show up after the black screen showed up.

Tell if that worked for you

Benoît Sansregret

signaturesignature

2016-08-05_09-07-09.png
Clock3 yrs

Hi Benoit,

sorry for my late answer, I was on holiday last week.
I tried to increase the Initial wait value at a few SSH sessions but it doesn't work for me. The sessions are to local servers, so the prompt is ready within a second. I tried values up to 30 seconds, but while it works on Windows without a problem it doesn't work on Mac at all. The other settings are like in your screenshot. Is there something else I can check?

Best regards,
Andreas

Clock3 yrs

Hi Andreas,

Clearly, I'm missing something here.
Could you post some screen capture of your configuration and the session opening?

I made a small video of how the session opens for me using a macro like yours maybe you'll notice something different from yours
https://www.dropbox.com/s/rb90xmiu40f1fuo/2016-08-16_09-25-44.mp4?dl=0

Best regards,

Benoît Sansregret

signaturesignature

Clock3 yrs

Hi Benoit,

yep, that's how it should work smile
I captured a video on my Mac, maybe you see something wrong on it: (edit: removed link)

Best regards,
Andreas

Clock3 yrs

Hi Andreas,

I found your issue and fixed it.
I wasn't able to reproduce your issue because I was using the SSH Shell entry and not the SSH Shell (Native) one.
Behind the seen when you are using the Embedded Display they use the same component but there is an issue with the After Connect Macro.

The fix will be released with the next version (which should be released by the ned of the month).
In the meantime, you can use the SSH Shell entry.
If you have too many existing entries that you also use in Windows tell me I will see what I can do.

Best regards,

Benoît Sansregret

signaturesignature

Clock3 yrs

Hi Benoit,

thank you for fixing this and letting me know about the possible workaround. I think we will simply wait for the next version.

Best regards,
Andreas

Clock3 yrs