Forum / Remote Desktop Manager - Bug Report

Greater Than Character doesn't work in Macro if stored in Custom Variable

  • Create an Issue
  • Cancel

Hy RDM Team,
I have a typing macro that types into a putty session to collect machine information and creating a mailsubject and mailbody and send the stuff to the admin, who is running the script.

Therefore output of commandline tools is stored in a temporary file via output redirection with ">". This works fine as the macro is stored in the sessions "After Connect" "Typing Macro" box.
The fun starts if the macro is copied to the "Custom Variables" of RDM for global use. If the Macro is run, all the ">" characters are replaced by their html reference "& gt;"
Is this intended bahavior or is there any way to escape the character in the custom variable?


Kind regards

Clock3 yrs

Hello,

I'll take a look at this issue.

Regards,

Hubert Mireault

signaturesignature

Clock3 yrs

Hello,

I checked and unfortunately, this is a limitation on our end for which we currently have no solution.

There is a workaround, though. You can use the "After login commands" section of the PuTTY entry and enter your command (with variables) there, and it should work. I tested it on the latest stable release of RDM enterprise and I found no issue using this workaround. Could you check if this works for your case?

Regards,

Hubert Mireault

signaturesignature

Clock3 yrs

Hi Hubert,

thanks for clarifying. I know that it works if the macro is directly filled into the session. We have 50+ of these sub-sessions since the time where custom global variables weren't available. But now as I have to make changes on all of these, I just wanted to take the opportunity to change it to the custom variable option for easier changes the next time.

But I found a viable way to overcome the limitation: I realized that the pipe symbol works correctly. So for now I use the "| tee" command to redirect the output accordingly.

So maybe you could add a list of "disallowed" or "not working as expected" characters to the documentation of the custom variable feature...

Kind regards

Clock3 yrs

Thank you for the feedback. From what I can see it should only be with "<" or ">" characters due to the underlying data format being XML-based (you can easily see this if you export an entry in RDM).

Regards,

Hubert Mireault

signaturesignature

Clock3 yrs