Forum / Remote Desktop Manager - Feature Request

Save password in WMware connection

  • Create an Issue

Hello,


This mode of operation uses the vpxclient executable. It does not allow for passing the password over the command line.


Best regards,



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock3 yrs

I see, thanks for the reply!

Clock3 yrs

I just realized, the password seems to be passed from RDM to the vSphere client. So why isn't possible to do it from the connection properties?

image

Clock3 yrs

Hello,


Are you still talking about the screenshot from the original post?

That form, depending on the dropdown selection operates against :

  • vpxclient.exe
  • vmplayer.exe
  • vmware.exe

When the dropdown is set as per screenshot above, the vpxclient.exe is used. This one does not allow for receiving passwords.

Best regards,




Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock3 yrs

Hi,

Yes, still talking about the original post. Something I don't understand here: you're saying that the vpxclient.exe does not allow for receiving password, but as you can see in my second screenshot (this is the window that opens after opening the connection shown in the first screenshot), it is RDM that is passing the password.

What am I missing here?

Clock3 yrs

We cannot understand with only your screenshots.

Please export the relevant entries, but without including the credentials. Send them at support@devolutions.net so we better understand.



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock3 yrs

Let me try again to explain it:

image

It seems to me that the password is passed to the vSphere client by RDM (from the 2nd window here above), thus I cannot understand why you are stating the contrary.

Sorry for not being clear and thanks for your help. Let me know if that makes more sense to you.

Clock3 yrs

Hello,


I had looked at the code to see which toggle caused the password box to be disabled, hence my previous answer.

I just realized that you were using the Free Edition, which disables the password box as well. I will let David answer if he wants to remove that limitation.

Best regards,



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock3 yrs

Hi,
We will remove the limitation. That an old restriction that we had a long time ago.

Sorry about that

Regards

David Hervieux

signaturesignature

Clock3 yrs

Hi,
Don't worry it's our fault. Sometime it's confusing with all the technologies that we integrate. We are planning to release a new RDM Free version this week with the fix for your issue.

Regards

David Hervieux

signaturesignature

Clock3 yrs