Forum / Remote Desktop Manager Mac - Support

RDP embedded or Undocked brings up a white screen

  • Create an Issue
  • Cancel

Hi,

When I try to connect (Version 3.5.3.0) to RDP undocked or even embedded, I get just a white screen. Via external application it works but there I'm having the issue that my credentials aren't forwarded. (Microsoft remote Desktop) But that is known issue.

Can I use another RDP software instead of Microsoft Remote Desktop that will work with the saved credentials?

Clock4 yrs

Hi,

Unfortunately, it's not possible to choose the app you use for the external display.
Do you have one in mind that we might look into it?

We have a few settings that might have an impact on your situation.
Do you mind trying to change the codec level?

Codec+levels+2016+06+01

Tell me if it helped you

Benoît Sansregret

signaturesignature

Codec levels 2016-06-01.png
Clock4 yrs

Thanks, Benoît.

Changing the codec fixes my problem. For some sessions I need to choose level 6, others level 8 but that's a small trouble.
It makes the day more exciting :-)

Clock4 yrs

May I ask you what's your server version?

Maybe there is something we can do to enable the other codecs properly.

Thank you

Benoît Sansregret

signaturesignature

Clock4 yrs

What server do you mean? The ones I connect to?

Clock4 yrs

I'm sorry my question was confusing.

I want to know the servers you need to set the codec level to 6, what version of windows are they running?

We will try to reproduce your issue and see if we can fix what is going on.

Benoît Sansregret

signaturesignature

Clock4 yrs

Well one server with level 8 is a server 2012 R2 Standard edition.
The other where I can connect to setting the codec to level 6 (level 7 also is fine but not level 8) is also a server 2012 R2 Standard edition.

With a Server 2008 R2 SP1 I don't need to change the codec.

Clock4 yrs

Thank you for the information.

Can you think of any difference between the 2 Win 2012 R2 servers?

Otherwise, we'll be on the look out for issue around the codec level 8 and try to find what wrong with some servers.

Benoît Sansregret

signaturesignature

Clock4 yrs

I also have Windows Server 2012 R2 Standard where I can leave the codec to default.
The ones that are giving me troubles also have certificate issues. Can that be the cause?

Clock4 yrs

If you didn't change your preferences about the codec, Default means level 8.

I don't see how the certificate could affect our situation but I'll ask the devs that specialize with the embedded RDP sessions.

I'll post here if we need more information or if we found something.

Benoît Sansregret

signaturesignature

Clock4 yrs

Sorry, I forgot to ask you for one last piece of information.

Can you send us a log of a session that doesn't work with codec level 8?
If you don't know how to configure it you can follow the instruction provided here: How to enable and send RDP Logs

Thank you for your feedback

Benoît Sansregret

signaturesignature

Clock4 yrs

Here's the log:

[08:37:58:052] [4561:b031d000] [INFO][com.freerdp.client.mac] -[MRDPIPCClient initLoggingWithFilter:filePath:fileName:] 117 - Log initialized headless
[08:37:58:053] [4561:b031d000] [DEBUG][com.freerdp.client.mac] -[MRDPIPCClient configureInternal] 90 - configureInternal
[08:37:59:023] [4561:b031d000] [ERROR][com.freerdp.common] freerdp_set_param_bool 1688 - freerdp_set_param_bool: unknown id 3392 (param = 1)
[08:38:00:334] [4561:b0421000] [INFO][com.freerdp.client.common.cmdline] freerdp_client_load_static_channel_addin 2492 - loading channel rdpdr
[08:38:00:334] [4561:b0421000] [INFO][com.freerdp.client.common.cmdline] freerdp_client_load_static_channel_addin 2492 - loading channel rdpsnd
[08:38:00:349] [4561:b0421000] [DEBUG][com.freerdp.channels.cliprdr.client] cliprdr_VirtualChannelEntry 1365 - VirtualChannelEntry
[08:38:00:349] [4561:b0421000] [INFO][com.freerdp.client.common.cmdline] freerdp_client_load_static_channel_addin 2492 - loading channel cliprdr
[08:38:00:443] [4561:b0421000] [DEBUG][com.freerdp.channels.drdynvc.client] drdynvc_VirtualChannelEntry 1626 - VirtualChannelEntry
[08:38:00:443] [4561:b0421000] [INFO][com.freerdp.client.common.cmdline] freerdp_client_load_static_channel_addin 2492 - loading channel drdynvc
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_set_negotiation_enabled 1193 - Enabling security layer negotiation: TRUE
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_set_restricted_admin_mode_required 1205 - Enabling restricted admin mode: FALSE
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_enable_rdp 1227 - Enabling RDP security: TRUE
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_enable_tls 1239 - Enabling TLS security: TRUE
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_enable_nla 1251 - Enabling NLA security: FALSE
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_enable_ext 1263 - Enabling NLA extended security: FALSE
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_connect 154 - state: NEGO_STATE_TLS
[08:38:00:444] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_attempt_tls 466 - Attempting TLS security
[08:38:00:803] [4561:b04a3000] [DEBUG][com.freerdp.core.transport] transport_client_thread 1010 - Asynchronous transport thread started
[08:38:00:803] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_send_negotiation_request 858 - RequestedProtocols: 1
[08:38:00:824] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_process_negotiation_response 923 - RDP_NEG_RSP
[08:38:00:824] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_recv 597 - selected_protocol: 1
[08:38:00:824] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_connect 168 - Negotiated TLS security
[08:38:00:824] [4561:b0421000] [DEBUG][com.freerdp.core.nego] nego_security_connect 221 - nego_security_connect with PROTOCOL_TLS
[08:38:01:270] [4561:b0421000] [DEBUG][com.freerdp.client.mac] -[MRDPIPCClient validateX509Certificate:] 551 - validateX509Certificate
[08:38:07:796] [4561:b0421000] [DEBUG][com.freerdp.core.gcc] gcc_read_server_security_data 1039 - Server rdp encryption method: NONE
[08:38:07:029] [4561:b0421000] [DEBUG][com.freerdp.core.rdp] rdp_recv_data_pdu 814 - recv Synchronize Data PDU (0x1F), length: 22
[08:38:07:029] [4561:b0421000] [DEBUG][com.freerdp.core.rdp] rdp_recv_data_pdu 814 - recv Control Data PDU (0x14), length: 26
[08:38:07:029] [4561:b0421000] [DEBUG][com.freerdp.core.rdp] rdp_recv_data_pdu 814 - recv Control Data PDU (0x14), length: 26
[08:38:07:029] [4561:b0421000] [DEBUG][com.freerdp.core.rdp] rdp_recv_data_pdu 814 - recv Font Map Data PDU (0x28), length: 26
[08:38:07:029] [4561:b0421000] [DEBUG][com.freerdp.client.mac] mac_post_connect 902 - sizes mfc 0x0 mfc->client 1920x1027 settings 1920x1027 physical 0x0
[08:38:07:031] [4561:b0421000] [DEBUG][com.freerdp.client.mac] mac_post_connect 925 - gdi initilialized with shared memory name:/uKmcmDpCjUWbDykqWL9X8g Id:32 addr:0x041f2000 size:7887360 gdi primary 0x041f2000
[08:38:07:031] [4561:b0421000] [DEBUG][com.freerdp.client.mac] -[MRDPIPCClient postConnect:] 500 - postConnect
[08:38:07:043] [4561:b0421000] [INFO][com.freerdp.channels.drdynvc.client] dvcman_load_addin 255 - Loading Dynamic Virtual Channel rdpgfx
[08:38:07:043] [4561:b0525000] [INFO][com.freerdp.channels.rdpdr.client] devman_load_device_service 179 - Loading device service smartcard (static)
[08:38:07:044] [4561:b0421000] [DEBUG][com.freerdp.channels.drdynvc.client] dvcman_register_plugin 114 - register_plugin: num_plugins 1
[08:38:07:044] [4561:b0421000] [DEBUG][com.freerdp.channels.drdynvc.client] dvcman_create_listener 62 - create_listener: 0.Microsoft::Windows::RDS::Graphics.
[08:38:07:044] [4561:b0421000] [DEBUG][com.freerdp.channels.rdpgfx.client] rdpgfx_plugin_initialize 1335 - Initialize
[08:38:07:044] [4561:b0525000] [INFO][com.freerdp.channels.rdpdr.client] devman_load_device_service 179 - Loading device service printer (static)
[08:38:07:049] [4561:a41ca000] [DEBUG][com.freerdp.client.mac] __mac_post_connect_block_invoke 984 - timer start
[08:38:07:049] [4561:a41ca000] [DEBUG][com.freerdp.client.mac] __20-[MRDPClient resume]_block_invoke 149 - timer resume
[08:38:08:207] [4561:b04a3000] [DEBUG][com.freerdp.core.transport] transport_client_thread 1025 - connectedEvent event triggered
[08:38:08:207] [4561:b0421000] [DEBUG][com.freerdp.client.mac] -[MRDPIPCClient viewDidConnect:] 393 - viewDidConnect

Clock4 yrs

Hi Steven,

One thing that seems strange is the resolution that is specified (1920x1027).
Is it a conscious choice or is it just a because it's an embedded session which fills up the empty space.
Would you mind setting the resolution to a normal one and see if the problem still occur?

RDP+Display+Settings+20160602

Best regards,

Benoît Sansregret

signaturesignature

RDP Display Settings 20160602.png
Clock4 yrs