Forum / Remote Desktop Manager - Feature Request

add agent forwarding to ssh shell

  • Create an Issue
  • Cancel

The SSH Shell connection has no option (AFAIK) to allow agent forwarding. (Using pageant here for my keys)

Clock3 yrs

Hello Hans,

Sorry for the delay. What version are you on? If you try out RDM 11.5.2.0 (the latest stable release) you should see the following in SSH Shell entries:

2016 05 26 07 43 03

This works with our key agent (found in the tools section of the RDM ribbon) and it should work with Pageant. Could you try it out and see if it works in your case? Thank you.

Regards,

Hubert Mireault

signaturesignature

2016-05-26 07-43-03.jpg
Clock3 yrs

that only allows for initial authentication. Agent forwarding ( '-A' with putty ) allows for key authentication within that session.

Clock3 yrs

You're right, we will add this feature for the next minor update as another checkbox alongside "use agent" for "allow agent forwarding". Thank you! smile

Regards,

Hubert Mireault

signaturesignature

Clock3 yrs