Forum / Devolutions Password Server - Support

Connections Tab in DVLS has no information

  • Create an Issue
  • Cancel

Hello,
I am new to Devolutions Server Console and just got it up and running with a temp license provided by you all so I can test. I finally got everything working and now when I go into the Web Interface I see the Dashboard, My Account, Admin, Reports, Configuration, and Help but when I go into Connections, none of my rdp connections that exist in the database with Remote Desktop Manager are there at all in the Web Interface. I have tried running Internet Explorer and Google Chrome and I get the same results every time. I have sent in two emails since yesterday as well with this information and I have gotten nothing in return. Please help. todd_green@xtoenergy.com
image

Clock4 yrs

Hello,

As per our emails from the support mailbox, I still see no responses to our emails, only screenshots for the same issue.

We must follow a diagnosis process and cannot achieve that with the information provided to us.

Best regards,



Maurice Côté

signaturesignature

Clock4 yrs

I told you all that I was able to get past the error I was having by loading .NET 4.6.1 and I know that was in an email to you all. I can now log into the DVLS website without issue and I can browse the configuration which tells me that I do not need to create a new DVLS instance and point to a new SQL database as you requested as you have no idea what kind of security and trouble I would need to go through to create those.
So, if DVLS is working now, what could be causing the "Connections" tab to not be populated in DVLS as that seems to be the only thing that is not showing up.
Thank you
Todd

Clock4 yrs

Hello,

as you have no idea what kind of security and trouble I would need to go through to create those.

I will discuss with management to see what we can do with that new information.

There is a bug with displaying images, that will be fixed in a coming release.

As for the connection list being empty, that's what we cannot reproduce.

Best regards,



Maurice Côté

signaturesignature

Clock4 yrs

So, I was able to delete all DVLS on my server. I started over and did a reinstall of DVLS and added a new DVLS instance and setup and created a brand new database. After some configuration I was able to make this work. Went through RDM and created a new connection and then went to DVLS and was able to see that new connection. So, in RDM I pointed to my 600 servers in the Session tab of my old database and exported all entries. Then went into the new database and imported all entries back in. Went into DVLS and was able to see all my 600 connections with the folder structure! Great Day!
Now the bad news. I was unaware that you cannot just go to another server or workstation and connect to the DVLS web on that server or workstation and be able to connect to a session "without" having RDM loaded on that server or client as well. The whole purpose of running DVLS is so that users could connect to the website and connect to their servers via the web console while utilizing active directory group security via roles on the backend to control this. If each user or server has to also have the RDM piece loaded as well then what is the good in that. Please fill me in on if I am doing something wrong here.
Other bad news is that Internet Explorer cannot be used at all and see any icons and then Google Chrome just sees little boxes and no graphics. When is this going to be fixed?
At least everything seems to be working now except for above.

Clock4 yrs

Now the bad news.


I was unaware that you cannot just go to another server or workstation and connect to the DVLS web on that server or workstation and be able to connect to a session "without" having Remote Desktop Manager Client loaded on that server or client as well. The whole purpose of running DVLS is so that users could connect to the website and connect to their servers via the web console while utilizing active directory group security via roles on the backend to control this. If each user or server has to also have the Remote Desktop Manager Client piece loaded as well then what is the good in that.


Please fill me in on if I am doing something wrong with the configuration of DVLS here.

Other bad news is that Internet Explorer cannot be used and be able to see any icons and then Google Chrome just sees little boxes and no graphics. I know you said you all are working on a fix for this. When is this fix going to be out and will it fix both IE and Chrome or just Chrome?


Thank you
Todd Green

Clock4 yrs

Hello,

You cannot launch or edit sessions through the DVLS web interface. This needs to be done via RDM.

Yes, each user need RDM installed on their computer to be able to launch remote connections.

DVLS will be used for the AD integration, 2FA and for the extra layer between your clients and the database.

You can consult the following blog on DVLS for more details and reasons why you should use DVLS
https://blog.devolutions.net/2016/03/5-reasons-to-choose-devolutions-server.html

For the images issue, this is a bug and this will be fixed in a coming release.

Best regards,



Jeff Dagenais

signaturesignature

Clock4 yrs