Forum / Remote Desktop Manager Mac - Support

RDM Mac 3.0.10.0 doesn't connect via RDG when using LastPass lookup for destination host (again)

  • Create an Issue
  • Cancel

Since the earliest releases of the Mac product, there have been issues with connecting to a remote RDP host via a Remote Desktop Gateway where the RDG credential is stored locally and the destination userid/password is retrieved via a LastPass credential.

Entries that work perfectly in RDM Windows that are exported and then imported into RDM Mac simply don't work. Worse, there's nothing in the application log and nothing is logged to the file specified in the Advanced tab of the RDP entry.

Suggestions would be appreciated on how to debug this.

Clock4 yrs

Resolved.

Apparently, in RDM Mac for a non-domain-joined RDG, you cannot supply a userid in the form host\user.

This works just fine in RDM Windows but not RDM Mac.

Clock4 yrs

Ooopsss...spoke too soon.

I have two Macs, both running the same level of OS (10.11.3). If I export all RDM entries from the Mac on which I am able to connect via RDG to remote servers, then import them (with credentials) to the other Mac, none of the entires connect. This includes entries that are on the local LAN. Microsoft Remote Desktop connects perfectly to both local and RDG remote sessions.

The error message is "not connected" and, as ever, there's nothing in the application log. Nor is anything recorded in the session log specified on the Advanced tab of the connection.

I also tried importing the sessions and credentials from RDM Windows (no luck) and re-installing RDM Mac (also no joy).

Clock4 yrs

Is there a way to completely remove and re-install RDM Mac? See the screenshot. The entries are identical, yet the larger image (from the Mac on which no remote or local sessions will connect) has missing icons on the home tab.

2016+03+06+10+22+41

2016-03-06_10-22-41.jpg
Clock4 yrs

Hi,

I'm surprised by this bug. Is it permanent? Does changing ribbon tab fix it? What about restarting the application?

May I ask what's your version of RDM?

Usually downloading the app and moving it to your app folder is all that should be required to reinstall RDM. If by completely remove the app, you mean the config and other resources used by RDM, you can delete de following folder:
/Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager

Be aware it would result in the permanent deletion of you configuration (be it your datasources configurations or your preferences). I advise doing a backup of this folder.

To be frank, I doubt reinstalling would fix the issue but it might be worth to try.

Best regards,

Xavier Fortin

signaturesignature

Clock4 yrs

I suspect the difference between the two Macs was that the one with the issues has been running RDM Mac off and on (mostly off) since the late beta stages over a year ago.

Deleting the folder you mention above and reinstalling from scratch worked.

BTW, I tried simply re-installing from the .dmg. That didn't fix it.

Clock4 yrs

Well, you have me surprise.

I'm happy it fixed your problem though.

Xavier Fortin

signaturesignature

Clock4 yrs