Forum / Remote Desktop Manager - Support

Windows Integrated Authentication on a Workgroup cmputer

  • Create an Issue
  • Cancel

In reading the Online Help, it indicates that my Windows login must be the account I want to use to log in to SQL Server connection when using Windows Authentication. However, I must run my computer in Workgroup mode and I cannot use SQL authentication due to security requirements. Most programs support this configuration. Is there any way in RDM to specify my AD credentials within the SQL Server connection screen, just as there are for SQL authentication credentials?

Clock4 yrs

You must start RDM with "runas /netonly" as described here:

http://help.remotedesktopmanager.com/index.html?tipsandtricks_runas_rdm.htm

Stefane Lavergne

signaturesignature

Clock4 yrs

Yes, that was what I read. I'm asking if there could be the option to manually enter my AD credentials for that connection since RunAs doesn't work for a domain that is not in the forest trust of the computer. The Workgroup computer is not even in an AD domain. I've seen other programs connect to SQL using Windows Authentication with manual credentials, which is what this would be.

Clock4 yrs

You must use /netonly this will not validate the credentials but pass them token along to the SQL server for validation.

It is impossible to supply AD credentials to SQL Server any other way. This is a SQL Server limitation and is by design. Same thing goes with SSMS (SQL Server Management Studio), if you run it with runas /netonly it will work but supplying your AD credentials in the SSMS username/password will not.

We have a server product (DVLS) which puts a web front end (+ API) on-top of SQL Server. With DVLS we do support supplying AD credentials.

Best regards,

Stefane Lavergne

signaturesignature

Clock4 yrs

Thanks. I wasn't understanding that the /netonly option worked on workgroup computers. I have it working now.

Clock4 yrs