Forum / Password Vault Manager - Support

Auth problems with PCs not joined to domain

Hi,
we are evaluating PVM enterprise and we are using SQL server as data source.
With domain-joined PC and using "Integrated Security (Active Directory)" we are able to connect.
However we have some PCs that are not joined to our domain so we tried unchecking "Integrated Security (Active Directory)" and typing in a valid AD user (that has all the permission needed in SQL server).
With this method we are unable to connect, the SQL instance is returning this error:

Login failed for user '<domain>\<user>'. Reason: Attempting to use an NT account name with SQL Server Authentication

We have also tried every kind of username '<user>', '<user>@<domain>' but none of them worked.

The SQL server is already configured in mixed mode auth.
Is there a way to connect to a SQL datasource without using the integrated security?

Thank you
Kind regards

Clock3 yrs

Hello,

You would need to run PVM as another user.

Please have a look at this help topic: http://help.remotedesktopmanager.com/tipsandtricks_runas.htm

Best regards,



Jeff Dagenais

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock3 yrs

Thank you for your quick reply.
Unfortunately, these PCs don't have any kind of domain account (they are not even joined), so executing PVM as a domain user is not possible (there's only a local admin user).

Do you have any other suggestions?

Thank You
Kind Regards.

Clock3 yrs

SQL server will not authenticate via active directory (AD) if you specify the username/password, it will needs a security context. It's a SQL server thing, as designed, for security reasons.

So you must run under the context of that user. Your only option is to use runas /netonly as describe here:

http://help.remotedesktopmanager.com/index.html?tipsandtricks_runas.htm

Best regards,

Stefane Lavergne

signaturesignature

Clock3 yrs

The runas with /netonly option did the trick!
Thank you very much!

Kind regards

Clock3 yrs