Forum / Remote Desktop Manager Mac - Support

RDM for Mac and pinwheel of death

  • Create an Issue
  • Cancel

Was occassional, now everytime I try to run the program I get the pinwheel. Force quit and restart no longer helps.

Loved the program on Windows, but it seems too buggy for Mac right now. Any help would be appreciated.

Clock4 yrs

Hello,
Could you give me more detail on what version you use and on what OS you are?

David Hervieux

signaturesignature

Clock4 yrs

Hi,

May I also ask what kind of data source your application startup on?

Regards,

Xavier Fortin

signaturesignature

Clock4 yrs

I have the same problems, mainly after some inactivity.

We are using Devolution server with Google authenticator for 2fa.
After starting RDM it comes 2 times with a popup box for 2fa.

it feels like a problem with 2fa, don't have proof.
Database error's in the application log.

What to do?

in the RDM application log;


[18-1-2016 11:10:56]ERROR SILENT The peer connection was lost.
[18-1-2016 11:50:01]ERROR SILENT The peer connection was lost.
[18-1-2016 11:51:01]ERROR SILENT The peer connection was lost.
[18-1-2016 12:42:15]ERROR SILENT The peer connection was lost.
[18-1-2016 12:44:43]ERROR SILENT The peer connection was lost.
[18-1-2016 13:35:07]ERROR SILENT The peer connection was lost.
[18-1-2016 13:51:37]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/petervanderveen/Library/Application Support/com.devolutions.remotedesktopmanager/9742A73F-4D0F-4C88-AF7A-54AA51C12F9D/offline.db
[18-1-2016 13:51:37]INFO ClearCache - Offline file has been deleted, recreating new file
[18-1-2016 13:51:37]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/petervanderveen/Library/Application Support/com.devolutions.remotedesktopmanager/9742A73F-4D0F-4C88-AF7A-54AA51C12F9D/offline.db
[18-1-2016 13:51:37]INFO ClearCache - Offline file has been deleted, recreating new file
[18-1-2016 13:51:37]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/petervanderveen/Library/Application Support/com.devolutions.remotedesktopmanager/9742A73F-4D0F-4C88-AF7A-54AA51C12F9D/offline.db
[18-1-2016 13:51:38]INFO ClearCache - Offline file has been deleted, recreating new file
[18-1-2016 13:51:38]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/petervanderveen/Library/Application Support/com.devolutions.remotedesktopmanager/9742A73F-4D0F-4C88-AF7A-54AA51C12F9D/offline.db
[18-1-2016 13:51:38]INFO ClearCache - Offline file has been deleted, recreating new file
[18-1-2016 13:51:38]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/petervanderveen/Library/Application Support/com.devolutions.remotedesktopmanager/9742A73F-4D0F-4C88-AF7A-54AA51C12F9D/offline.db
[18-1-2016 13:51:38]INFO ClearCache - Offline file has been deleted, recreating new file
[18-1-2016 13:51:38]INFO Offline file - Database disk image is malformed, trying to delete the file: /Users/petervanderveen/Library/Application Support/com.devolutions.remotedesktopmanager/9742A73F-4D0F-4C88-AF7A-54AA51C12F9D/offline.db
[18-1-2016 13:51:38]INFO ClearCache - Offline file has been deleted, recreating new file


MAC OS-X El Capitan 10.11.2 (15C50) and RDM 3.0.8.0

Clock4 yrs

Are you always getting prompt twice for two factor, or is it only after force quitting the application?

Xavier Fortin

signaturesignature

Clock4 yrs

Xavier,

This happens always.

Also when i close RDM, it expands all the folders (where the entry's are located). this takes a lot of time.

gr,

Peter

Clock4 yrs

Just so I understand. It prompt you twice for the two factor but you're still able to connect, right?

And when you say it expands all folder, are they still expanded when you start the application?

Xavier Fortin

signaturesignature

Clock4 yrs

Just so I understand. It prompt you twice for the two factor but you're still able to connect, right?

Yes, thats correct.

And when you say it expands all folder, are they still expanded when you start the application?


No, they are back again the way you left it, some expanded some collapsed

Clock4 yrs

Thank you.

I've reproduced those two issues and they should be fixed for the next version.

Best regards,

Xavier Fortin

signaturesignature

Clock4 yrs

Wow thats amazing fast!

thanx

Peter

Clock4 yrs

Just to mention I'm still investing the pinwheel issue though.

Xavier Fortin

signaturesignature

Clock4 yrs

David Hervieux wrote:

Hello,
Could you give me more detail on what version you use and on what OS you are?


David,

Running OSX 10.11.2

RDM for Mac version 3.0.5.0

Clock4 yrs

Xavier Fortin wrote:

Hi,

May I also ask what kind of data source your application startup on?

Regards,

Startup is local data source.

Clock4 yrs

Hi jeffh,

Can you download the latest version (3.0.8.0) and tell me if you're still unable to start the application successfully.

Could you also send me (through private message) your log file. It should be /Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager/RemoteDesktopManager.log.

Best regards,

Xavier Fortin

signaturesignature

Clock4 yrs

Xavier Fortin wrote:

Hi jeffh,

Can you download the latest version (3.0.8.0) and tell me if you're still unable to start the application successfully.

Could you also send me (through private message) your log file. It should be /Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager/RemoteDesktopManager.log.

Best regards,

I did download that version, but it is only the enterprise trial. I was using the free version before that only appears to go up to 3.0.7.0. I will pm the logs now.

Clock4 yrs

And was the enterprise trial working correctly? And what about the Free 3.0.7.0?

Xavier Fortin

signaturesignature

Clock4 yrs

And I didn't realize you were using the Free edition. You should find the right log file at the following location : /Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager.free/RemoteDesktopManager.log.

Xavier Fortin

signaturesignature

Clock4 yrs

Xavier Fortin wrote:

And was the enterprise trial working correctly? And what about the Free 3.0.7.0?

Enterprise version installed yesterday 3.0.8.0 seems to be working properly.

Clock4 yrs

Xavier Fortin wrote:

And I didn't realize you were using the Free edition. You should find the right log file at the following location : /Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager.free/RemoteDesktopManager.log.


Most recent version 3.0.7.0 seems to be better. I want to kick the tires a few days to be sure, but it may be fixed in this version.

Clock4 yrs

Hey there, sorry to bump this thread, but I couldn't find a way to make a new topic, and this is kinda a problem I'm having.

My RDM does take a while (about 45 seconds to load), but I can live with that. I'm trying to figure out how to tweak the display settings so streaming video is more fluid. I check in on quite a few NVR's and the camera feed data seems to lock up RDM.

Ideas? and thanks! (and if I knew how to make a new post I would)

Clock4 yrs

Hello Nicholas,

Is it possible for you to post some print screens of the issue.

Best regards,



Jeff Dagenais

OFFICE CLOSURE!
Although our various support queues will be monitored for emergencies, Devolutions' offices will be closed on October 14th 2019.

signaturesignature

Clock4 yrs

Well I've learned that its actually not as big a problem. The MAC versions is definitely slower than the PC version, but once its up it works just fine. So nice to be able to share these connections with my teammates! And the open external using the Microsoft RDP works great for the NVR.

So, no worries, Im good!

Thanks!

Clock4 yrs

I'm running 3.0.8 with SQL datasource. pinwheel comes up often, no obvious pattern that I've been able to detect. Which log file(s) are needed to help diag the problem?

Clock4 yrs

Here also still the same problem.

Are you using 2FA?, it "feels" like the problem is after a small time of inactivity.

gr,

Peter

Clock4 yrs

no 2fa, and i was incorrect, its RDM server, not sql.

Clock4 yrs

May I ask how many entries there is in your datasource?

Some heavy duty operations might display the pinwheel. You've noticed absolutely no pattern, like after editing an entry, creating a new one? Is it bound to any particular actions?

You can always send me the application log so I can check it up:
/Users/<User>/Library/Application Support/com.devolutions.remotedesktopmanager/RemoteDesktopManager.log.


Best regards,

Xavier Fortin

signaturesignature

Clock4 yrs

Peter van der Veen wrote:

Here also still the same problem.

Are you using 2FA?, it "feels" like the problem is after a small time of inactivity.

gr,

Peter


Now that I think of it, I've never asked, but how much would be a little time of inactivity? I might be able to reproduce it.

Xavier Fortin

signaturesignature

Clock4 yrs

Jeff,

we now have 600 entry's, i expect it to grow to about 1000 entry's soon.
We just started using it.

When will the update for the double 2FA popup be released?

Gr,

Peter

Clock4 yrs

The next version should be out tomorrow.

Xavier Fortin

signaturesignature

Clock4 yrs

600 entries, man! I thought my 72 or so was alot haha

Clock4 yrs