Forum / Password Vault Manager - Support

Impact from changing Security Type

  • Create an Issue
  • Cancel

Good Day,
Right now we have our Security Provider set to default.
What is the impact from switching from Default to Basic or Certificate?
Is there a best practice guide for doing this?


Thanks

Clock4 yrs

Hello,


This will process the whole of your database to encrypt the content of the session details.

  • Plan the change with your colleagues, it may be worth it to have them enable the offline mode to have a working copy throughout the process
  • Ensure you are alone connected to the database
  • Decide on a passphrase and store it in a safe, we cannot help you if you lose it.
  • Backup the DB and store the bak file in a safe place (outside of the maintenance plan cleanup routine watched folders)
  • Apply the security provider
  • Each of your colleagues will need to enter the passphrase when they reconnect

Best regards,



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock4 yrs

Thanks for the detailed answer.

If For now I just change from Default to Basic.
What would be the impact?

Before going to Certificate I will try to do a dry run with a Test Database.

But I would like at least swicth from default to Basic.

Thanks

Clock4 yrs

nothing more/less then what I responded above

Just follow the procedure and you should be ok



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock4 yrs

So if I just switch from Default to Basic no major change or impact?

But If I switch from Default to Certificate then I need to follow your instructions?

Thanks

Clock3 yrs

I just changed from Default to Passphrase .... but PVM not asking for it when users are trying to login.

Clock3 yrs

Its working now.... not sure what I did, but after I restarted PVM it worked.

Thanks

Clock3 yrs