Forum / Remote Desktop Manager Mac - Support

Quick Connect templates

  • Create an Issue
  • Cancel

For the life of me, I am unable to get the quick connect to work like it does on Windows... it seems all the templates are always greyed out..
image

Am i missing something or does this not work like the windows side? Any insight would be greatly appreciated..
image

Clock4 yrs

Hi,

I've been able to reproduce your issue and I found a fix for it.
It will be available in the next release.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

Nice! thanks for the quick response Benoît - any general ETA on the next release? thanks again.

Clock4 yrs

Hi,

It should be available by the end of next week.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

i just had a chance to circle back to this.. looks like the templates are no longer greyed out, but it doesnt seem the quick connect box is honoring the template. basically i use the template for RD gateway settings - on Windows version, i am able to create a RDP template with gateway settings and simply put the computer name in the quick connect box and it will connect me to the machine through the gateway passing the credentials to the machine. on the current version, maybe i'm doing something wrong, but i've tried a few different ways and each time the quick connect will only simply launch an RDP session to the name i put in the quick connect box.. wont used RD Gateway or password settings in the template chosen... any idea?

Clock4 yrs

Hi Tim,

I'll check if I can find what is going on.
Thank you for reporting this.

Benoît Sansregret

signaturesignature

Clock4 yrs

Hi Tim,

I made a few tests and everything seems to work fine.
In my case I built a Local template with my Gateway informations, then I tried to connect to a server.
I selected my template and filled out the Host, User name (Domain\user format) and password.
QuickConnectwTemplate

Are you able to create a new entry using your template?
Right click on the navigation tree and select Add->Add from Template->Your template in the context menu.
Is the information all filled out correctly?

Best Regards,

Benoît Sansregret

signaturesignature

QuickConnectwTemplate.png
Clock4 yrs

i am only filling out the host name i(.e. server1, server2) not using any FQDN - i have created a remote desktop template and added the username and password in the template for both gateway and server and am using the quick connect variable which i understand pulls the name entered in the hostname and in to the template. Anything i use gets Failed to connect to the host (131084). If i enter a FQDN (i.e. server1.domain.com) it will connect not using any of my template settings and no saved credentials. Adding a new entry from template seems to carry over the settings fine... it's only quick connect that does not work.

Clock4 yrs

Hi Tim,

With what you are telling me, I can't find what is going wrong with the Quick Connect.
Just to make sure the problem is with the Quick connect could you create an entry with the your template and replace every $QUICK_CONNECT$ with a working host. Then try to Open the session.
If it's working the problem is with the Quick Connect otherwise with might have an other problem entirely and we will need to find what it is.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

Hello, apologies as i've been extremely busy but wanted to circle back to this as i've downloaded the latest release and it seems as though the quick templates still do not function. I've made the changes you requested and launching a session from quick connect simply does not work, almost as if it's not really applying the template. The only connection i can make is using a direct RDP connection and it will never pass credentials... it seems to simply be a means to start an RDP connection, no settings will ever apply.

Clock4 yrs

Hi Tim,

In my last message I was trying to identify if the problem was with the Quick Connect feature or if there was an error in the template configuration.

I wanted you to :
-Create a new session using your template (Right click on Sessions in the navigation tree Add>Add From Template>Your template
-Replace every occurence of $QUICK_CONNECT$ with a working host
-Save the new Session
-Open the session

Is the session connecting or is it failing the same way as when you use the Quick connect?

I know this is not the way you work normally but my point here is to try to find what is preventing you from connecting.

Best Regards

Benoît Sansregret

signaturesignature

Clock4 yrs

Creating a session does work as expected - following your instructions I was able to create a session without any issues and it connects just fine pulling the settings from the template. It's currently only the quick connect that proves to be an issue.

Clock4 yrs

I made a few mores tests and I can't seem to figure out what is going on.
May I ask you to export your template and send it to me in a Private message?
You can change the password before exporting it.
To export it go to the Remote Desktop Manager menu Default Settings->Templates...
Select your template an click the export button (it's the right most button).
I will try to find what is the problem in it.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

Hi Tim,

Good news, I was able find what was your problem and fixed it internally.
The fix will be available in the next release.
I know it is a blocking feature for you so I also sent you a link to a custom built version containing the fix in a private message.

Best Regards,

Benoît Sansregret

signaturesignature

Clock4 yrs

SUCCESS!!!!! Wow Benoit appreciate the persistence here, don't know how excited I am for this! Thanks again!

Clock4 yrs