Forum / Remote Desktop Manager - Feature Request

Enhancement request: credentials for remote management tools

  • Create an Issue
  • Cancel

RDM Enterprise 10.6.7.0

I've noticed that the remote management tools on the dashboard for RDP connections don't honor the specified credentials for said RDP connections. It seems they only pass through the credentials from the Windows session in which RDM is running. For the majority of the servers my company manages, this is fine, but there are a handful of environments for which there is no domain trust for various technical and security reasons, as well as several that are not connected to any domain, and the remote tools don't work for any of those servers.

So, is it possible to change things so that the management tools push through the credentials that apply to the RDP connection, instead of current Windows session credentials, or are there technical limitations making that impossible?

FWIW, in the scenario where I'm manually connecting management tools (compmgmt.msc, services.msc, etc.) to a remote server that's not in a trusted domain, I first browse to \\servername to get a credentials prompt and supply the appropriate credentials, after which the management tools will piggyback on that connection and connect to the remote server successfully.

Clock4 yrs

Hello,

The credentials used by the tools are in fact defined in the properties of each session, in the Tools tab.

By default, it uses your windows session, but you can choose "Session credentials", maybe even other credentials. Using the "User specific settings" you can even choose credentials from your private vault.

Best regards.



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock4 yrs

From what I'm seeing, that does not seem to be the case. I have RDP connections set to inherit credentials set via user-specific override on a parent folder, and I'm getting access denied errors on the management tools. I also tried setting user-specific override credentials directly on one of the RDP connections, and get the same result.

In case it matters, I'm just using the Custom option when specifying override credentials, and again, the Security setting on all RDP connections is set to Inherited.

Clock4 yrs

Maybe a bug crept up at the overrides are ignored, we will try to replicate it.

Thank you

TL;DR
Folder (credentials set with user specific settings)
Session (credentials set to inherited, tools set to "use session credentials)



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock4 yrs

Oh, wait a minute. I apologize, I completely missed what you said about the credentials setting for the tools in the session config. I just changed that from default to session, and now it works. Today seems to be one of those days where I skip half of everything I'm supposed to read. Anyway, sorry for the confusion, and thanks for the help!

Clock4 yrs

all good, happy that it works



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock4 yrs