Forum / Remote Desktop Manager Android - Bug Report

Remote Desktop Manager - Android Beta

  • Create an Issue
  • Cancel

I import existing xml file and all sessions show up perfectly fine.
However when I try to launch any session I get the following error message

"Connection error: Please verify your connection settings"

See screenshot attached.
rdp+scr
Same session works perfectly fine on Windows.

Thanks.

rdp_scr.png
Clock5 yrs

Hi Yuri,

Depending on your network configuration, the Android device could have a problem resolving the computer name address.

If you use a computer name for your computer name, can you try to change it for its IP address.


Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

Hi Nicolas,

Yes,it is IP address,not hostname,still same error message.And just to be clear,it is not this specific session but all remote desktop sessions from xml file I imported give same error message.
And same xml file works perfectly fine on Windows.


Thanks.

Clock5 yrs

Hi Yuri,

Can you export one session (in windows) and send it as an attachment to : ndufour@devolutions.net

It will be easier to analyze.

Thanks,

Nicolas Dufour

signaturesignature

Clock5 yrs

All done.

Clock5 yrs

Hi Yuri,

From our analysis, your connection does not have any special settings.

In Android, can you try to edit the connection, go to the RDP session information and press the Is Online button.

This function will try to ping the server.

It will perform 2 tests: Host Ping and Host port scan.

The test result will help us in our investigation.

Thank you,

Nicolas Dufour

signaturesignature

Clock5 yrs

There you go:

Host ping result: Failed
Host port scan result: Successful


I installed terminal emulator on my android device and tried to ping same host and pings perfectly fine so the problem is definitely with application itself.

Also you probably know disabling WAN ping is a common practice for security reasons so ping test might not be always relevant when troubleshooting connection issues.

Thanks.

Clock5 yrs

Hi Yuri,

Thank you for performing the test.

Our ping test may fail and is not 100% reliable (it has to be fixed).

The important test for RDP connections is the port scan test. This test is reliable.

This means that the connection/session can find the server and for some reason the server refuses the connection.

The most common connection problems are:
1- Invalid username or password
2- Using a credential type other than default can sometimes cause a problem
3- Setting the password to be saved on the local computer (this is currently not supported in Android)
4- If the connection it set to use Network Level Authentication or not

From our analysis your connection is very basic and everything seems to be ok.

Can you create a new RDP connection in Android (entering only the IP address, username and password) and test the connection ?

Can you provide us information about the Windows Server you are trying to connect to ?


Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

Nicolas,
I have around 100 connections in my xml file,all of them give same error message,so it is definitely not connection specific,even if I create new connection manually I get same error.When I click Launch,the screen changes to black for a few seconds with ip address on top and then fails.

Clock5 yrs

Hi Yuri,

The connection problem could have been related to a setting
on all your connections that Android does not handle properly.

By creating a new connection, we made sure the connection
settings were basic and minimal.

Could you please provide us with details of the Windows Server you are
trying to connect to ?

Have you had a chance to look at the Windows Server logs ?
This could help us find why the RDP session cannot be opened.

Have you tried to open an RDP session with the Microsoft Remote Desktop
application on Goole Play with the same setting (IP, username, password) ?
It will probably work, but we would like to confirm it.

Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

Hi Yuri,

Thank you for all the tests you have performed and the detailed information that you have provided us.

It will help us reproduce and fix the problem.

Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

Hi Yuri,

The launch session reliability has been improved for RDP connections in Version 1.05.
Can you try to open a session that wasn't working ?

Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

Hi Nicolas,

Exactly same problems,I can't see any difference at all(beta 1.05).
Am I missing something ?

Clock5 yrs

Hi Yuri,


We found and fixed an authentication problem that could occur with some of the session configurations.
Obviously, the fix has not solved the problem that you are experiencing.

When you click Launch, does the screen still changes to black for a few seconds with ip address on top and then fails ?

We will continue investigating.

Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

Yes,exactly same behavior.

When connection to nonstandard ports,it gives "Connection error:Please verify your connection settings".
When connecting to standard ports,it give the message above and after that "The peer connection was lost".

Both connection work fine with other remote desktop clients(both Windows and Android based)

Thanks.

Clock5 yrs

Hi Yuri,

Thank you.

We will continue investigating.

Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

Hi Yuri,


The port forwarding bug with a non standard port was reproduced in our lab.

The new version (1.06) should fix the problem.

Can you try to open a session that wasn't working ?


Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

My apologies for slow respnse,I was away.
I tried version .07 and progress is huge.


The following three issues I noticed:

1. I cannot figure out how to get "abc" keyboard.I can switch to function mode,number mode but I ca't see letters.

2. VNC sessions open as black screen

3. When open RDP session from vertical position after rotating screen to horizontal it won't adjust automatically and shows up as half screen.However when open RDP session from horizontal position everything is fine.


Thank you very much and keep up excellent work.

Clock5 yrs

Hi Yuri,
Sorry for the delay.

For the "abc" keyboard did you try to rotate your device ? On some devices the keyboard doesn't behave correctly in horizontal position.
Could you be more specific for the settings of your VNC session ? What differs from the default setting ? Are you using an IP address or a computer name ?
The rotating issue is a known one. It should be fixed in a future release.
Best regards,

André Sanscartier

signaturesignature

Clock5 yrs

Thanks,I can see "abc" keyboard in vertical position.Can it be implemented in horizontal position as well ?

For VNC connection I just use exactly same xml connection file from my windows desktop.The connection type is "TightVNC" and it works perfectly fine on Windows but on my Android device I only get black screen.

Thanks again.

Clock5 yrs

Hi Yuri,
For the horizontal position it's a known issue that we wish to solve.
I'll check with the VNC team to know what could be wrong with your setting.
Best regards,

André Sanscartier

signaturesignature

Clock5 yrs

Hi Yuri,

For VNC, can tyou try to connect to VNC and move your finger (or tap) on the black screen. At the same time can you check on the server if it reacts. This will help us determine if the problem is the screen updates on the android client or if the android client cannot connect to the host.

Regards,

Nicolas Dufour

signaturesignature

Clock5 yrs

I found the problem.
In my Windows version of RDM I have vnc sessions with preset VNC passwords(as command line arguments) but your android version is not able to read any arguments from Windows version.Like I said I use same xml connections file.
Hope you guys will fix it soon .

Thank you.

Clock5 yrs

Hi Yuri,

I'll add support for the command line arguments used by external vnc clients. They will overwrite settings set in the entry. Note that RDM won't, however, be able to support arguments from a stored vnc config file.

Jonathan Lafontaine

signaturesignature

Clock5 yrs

Hi Yuri,

I was wondering what command line arguments you were using for your external connections.
Are you exclusively using -password= ?

Jonathan Lafontaine

signaturesignature

Clock5 yrs

Yes,this is correct,I use "-password=12345"

Clock5 yrs

Command line arguments are now parsed and will overwrite connection's values.
Not all parsed value will be used. For now, host, port, username and password (where applicable) are supported.

The fix will be available in the upcoming release.

Jonathan Lafontaine

signaturesignature

Clock5 yrs

Hi,

I am having this same exact problem but the version I can download from Google Play is only .03. From where can I download the later beta versions please?

Thank you.

Clock4 yrs

Hi Dav,

At the moment, not all command line arguments are supported.
however some should work. Version 1.03 is the latest version available.

Can you please export your connection and send it to us, we will analyze it.
In your RDM Windows version:
1) Select the entry
2) Right click on the entry
3) Select export
4) Select export selection
5) Save the file and make sure to check the credentials checkbox
(you can change the current credentials password for an invalid one).
6) Send the .RDM file as an attachment to: ndufour@devolutions.net.

Best Regards,

Nicolas Dufour

signaturesignature

Clock4 yrs