Forum / Remote Desktop Manager - Feature Request

Cisco AnyConnect "Connect Anyway"

  • Create an Issue
  • Cancel

Hello,
In the AnyConnect plugin, can we change the "Connect Anyway confirmation" so that we can choose both Before and After authentication? I get prompted both before and after when connecting to most of my clients.

Thanks!

Clock4 yrs

Hi,
I will check with our Dev team for that.

David Hervieux

signaturesignature

Clock4 yrs

Thanks David!

Clock4 yrs

Hello,

There is now a combo box with 3 choices: "Before authentication", "After authentication" and "Both". This is available for download here: http://remotedesktopmanager.com/Home/AddOn

Regards,

Hubert Mireault

signaturesignature

Clock4 yrs

This is why I love you guys, thanks!

Clock4 yrs

I added this to my install but, when I tried it I received an error when I try the "both" choice. The Anyconnect confirmation dialog box popped up and went away quickly (as expected) but then another box came up "Failed to get configuration because AnyConnect cannot confirm it is connected to your secure gateway. Contact your system administrator."

If I go back to the Before Authentication choice, it does not clear the confirmation box at all.

I'm heading out to a client but, I can test this again later today.

Clock4 yrs

Hello,

The order of operation is not changed at all, so the behavior should be the same as before, just that it's now called at both points rather than only one of the two. Could you make sure it works when going manually? If it does, could you list every data-entering step so I can cross-check with our code to see if in your particular case something is out of order?

Regards,

Hubert Mireault

signaturesignature

Clock4 yrs

Sure I'm at a client I'll test it later

Clock4 yrs

I PM'd a link to a video of the problem.

Clock4 yrs

Thank you for the video, I think I know what the issue is. I will get back to you when I have made the changes to the add-on. At a glance, it will probably be an advanced settings combobox, but I will give you more information for the setting when it is done.

Regards,

Hubert Mireault

signaturesignature

Clock4 yrs

Hello,

I've created an updated version of the add-on and linked it in this post. Could you install it and see if it fixes your issue? The issue seems to come from the second prompt being an external window which is not accepted in the same fashion as the first one, in your case.
In the advanced tab for AnyConnect connections, there is a combobox to choose which of the "connect anyway" prompt is an external window. In your case, it would be the after connection "connect anyway" prompt.

Regards,

Hubert Mireault

signaturesignature

VPN3.0.12.0.zip
Clock4 yrs

Something strange - I put the file in the install folder but, the Add-on Manager still shows the old version number 3.0.11. If I go look at the file in "C:\Program Files (x86)\Devolutions\Remote Desktop Manager" the Details show 3.0.12.

For some reason, I can't seem to get it to update to 3.0.12. I tried Uninstall AddOn and Manual Install but, still it picks up 3.0.11, not .12. Obviously, I'm doing something wrong but, not sure what.

Clock4 yrs

Could you check to see if you have the 3.0.11.0 version of the add-on located in %Localappdata%\Devolutions\RemoteDesktopManager ? The one installed in local app data takes priority over the one in the program files.

Regards,

Hubert Mireault

signaturesignature

Clock4 yrs

I uninstalled the Addon via the AddOn Manager. I made sure the file was removed from both locations. I manually copied the file into the C:\Program Files (x86)\Devolutions\Remote Desktop Manager location. I checked the details of the file and it shows 3.0.12 but, the Addon Manager still shows 3.0.11. go figure.

Clock4 yrs

And the VPN still fails

Clock4 yrs

In the advanced tab of the AnyConnect connection settings, is there the combobox for "use window confirmation for 'connect anyway' prompt"? If it is there, it should be the 3.0.12.0 version nonetheless. If you put that combobox to "after authentication", does it work for your use case?

Regards,

Hubert Mireault

signaturesignature

Clock4 yrs

That checkbox is there and it fails with the same error as before. I'm on a different computer so I don't have the movie software but, when I get home tonight I will take a movie and send it to you.

Clock4 yrs

Second video posted.

Clock4 yrs

Here is an updated version of the add-on, the version is still 3.0.12.0 so you shouldn't see any UI difference, but it works slightly differently (tab instead of shift-tab to select the right option, as we discussed).

Regards,

Hubert Mireault

signaturesignature

VPN3.0.12.0[1].zip
Clock4 yrs

Perfect. I set the General drop down to Both and the Advanced drop down to After and it worked!

Thanks!

Clock4 yrs

Thank you for helping test it for us. This will be available on our website for download later today, too.

Regards,

Hubert Mireault

signaturesignature

Clock4 yrs

Hi

I am using 'Cisco AnyConnect Secure Mobility Client Version 3.1.14018' on Win XP, to connect to IBM PDP VPN network. However, I am getting error message "Connection failed"

I talked to IBM PDP person , he also did some trouble shooting. At the end he mentioned about some Group policy setting in Cisco client, which he was aware about.

Does anyone know how to fix this issue?

thanks
Atul

Clock2 yrs

@Atul,

We have seen with Cisco AnyConnect that the username or the password was not sent completely and this was causing a connection failed because the username or password is incomplete.

We have found that this issue was caused because of the UAC feature in Windows.

Could you try to disable or enable UAC on your computer depending of the setting that is already configured on your computer.

This link may help you to disable that feature - https://answers.microsoft.com/en-us/windows/forum/windows_xp-security/change-user-account-control-settings-in-xp/34175c91-374b-4879-9918-b5d5f95ac63d

Best regards,



Jeff Dagenais

signaturesignature

Clock2 yrs

Hi Jeff,

I checked user accounts in control panel, but, did not see the option which you mentioned. please take a look at screen shots.

thanks
Atul


Jeff Dagenais wrote:

@Atul,

We have seen with Cisco AnyConnect that the username or the password was not sent completely and this was causing a connection failed because the username or password is incomplete.

We have found that this issue was caused because of the UAC feature in Windows.

Could you try to disable or enable UAC on your computer depending of the setting that is already configured on your computer.

This link may help you to disable that feature - https://answers.microsoft.com/en-us/windows/forum/windows_xp-security/change-user-account-control-settings-in-xp/34175c91-374b-4879-9918-b5d5f95ac63d

Best regards,

xp user account.JPG
my user account.JPG
Clock2 yrs

@Atul,

After verification, it's seems that UAC doesn't exist on Windows XP, my apologies.

What version of RDM are you running?

What type of data source are you using?

When the error message appear exactly? Maybe post a print screen.

Best regards,



Jeff Dagenais

signaturesignature

Clock2 yrs