Forum / Remote Desktop Manager - Feature Request

keep alive

  • Create an Issue
  • Cancel

Hi,
we have some customers who have very short timeouts on the session, e.g it locks the screen. so we have to reconnect if we don't use it for a few mins.
is there anyway to keep this from happening? can you "inject" a movement to stop this?
James.

Clock5 yrs

Hello,

It depends on the remoting technology being used. For RDP there is a "Keep alive" setting in the Experience tab. Is this the protocol you were thinking of?

best Regards



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock5 yrs

That is indeed. how does the setting work?

Clock5 yrs

Hello,

This is a service offered by the Microsoft ActiveX for RDP, therefore we can use it only for embedded sessions.

Here's what their documentation says


Specifies an interval, in milliseconds, at which the client sends keep-alive messages to the server. The default value of the property is zero, which disables keep-alive messages. The minimum valid value of this property is 10,000, which represents 10 seconds. Note that a group policy setting that specifies whether persistent client connections to the server are allowed can override this property setting.

Note that we expose this value as seconds and we take care of the conversion.

As their doc mentions, there is a group policy at the server level, that one would fix your issues for External sessions as well.



Maurice Côté

Customers that use Devolutions Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

signaturesignature

Clock5 yrs

Right thanks, so how does the setting work then? do i set 10 for mins? more or less than the timeout?

Clock5 yrs