My company uses the CommVault Simpana enterprise backup software. The client is a JNLP client, and I'm able to get RDM to start it using the Java Web Start feature without problem. However, the first thing that the client does is ask for a username, password, and server. It would be great if RDM could supply that information.

What kind of information do you need to make that happen?

Here are screenshots of the login window and a window inspector with information on that window:

http://img838.imageshack.us/img838/9427/connecttocommcell201202.png

http://img703.imageshack.us/img703/6447/frozenautoitv3windowinf.png

Clock5 yrs

Hi,
Have you tried the auto typing feature in the Event tab page? This allow you to execute a macro after the connection.

David Hervieux

signaturesignature

Clock5 yrs

The Green "Play" arrow on the session goes away immediately after the Java splash screen, so I assumed that RDM wasn't tracking the process well enough to be able to perform auto typing. I tried it anyway to test and it turns out it does work. Almost.

First, it takes literally 30-40 seconds for the login screen to appear. So I set the initial delay to 40 seconds. (It would be nice if I could tell it to wait for the specific window to appear.)

I have told it to type:

$USERNAME${TAB}{DELAY}$PASSWORD${TAB}{DELAY}server.domain.com

However, both $USERNAME$ and $PASSWORD$ expand to nothing. I suspect that this may be due to how I have the credentials specified.

The session's credentials are set to a specific entry in the credential repository. Then the repository's entry is overridden with a "User Specific Setting". I suspect that this may be the same bug as being unable to copy those credentials to the clipboard.

I'm running v.6.6.0.0.

I suppose this has turned into a bug report and not a feature request. Sorry.

Clock5 yrs

Could you try the latest beta to see if it works?

http://remotedesktopmanager.com/download/Setup.RemoteDesktopManager.6.9.8.0.exe

David Hervieux

signaturesignature

Clock5 yrs

I don't have permissions to upgrade my database.

Clock5 yrs

Oh, I see. I pretty sure that we have fixed this bug. We will release soon the official version. Let me know at this time if this resolve the issue

David Hervieux

signaturesignature

Clock5 yrs

And now I can't downgrade. upset

Clock5 yrs

Will 6.6.0.0 clients still work if the database is upgraded to whatever 6.9.8.0 wants?

Clock5 yrs

You can download the zip content to downgrade:

http://remotedesktopmanager.com/download/Devolutions.RemoteDesktopManager.Bin.6.6.0.0.zip

I can't guarantee you at 100% that it will still work but it suppose to.

David Hervieux

signaturesignature

Clock5 yrs

wfaulk wrote:

Will 6.6.0.0 clients still work if the database is upgraded to whatever 6.9.8.0 wants?

Clock5 yrs

The client 6.6 should work but I can't guarantee you. Maybe we could find a case we missed.

David Hervieux

signaturesignature

Clock5 yrs

Hi wfaulk and David... Did you ever get this working? I was able to get a 'Typing Macro' containing my domain\username, password, and hostname all in clear text but that's not something I want available to everyone who uses RDM in our organization. I have been pulling my hair out trying to get the credentials to work. One problem I have is my %username% is different than the login I'm using to get into CommVault.

Clock4 yrs

Could you try to use the macro password variable to hide the information? You can also use the custom field in Information.

David Hervieux

signaturesignature

Clock4 yrs

David Hervieux wrote:

Could you try to use the macro password variable to hide the information? You can also use the custom field in Information.

I tried using the macro password but when I save it and go to edit it again my Typing Macro is displayed in plain text.

Clock4 yrs

The macro password field content is hidden with dots for me and it should be like that for you.

Could you post of print screen of what you see?

David Hervieux

signaturesignature

Clock4 yrs

This is my macro string that works:

domain\username{TAB}{DELAY}mypassword{TAB}{DELAY}hostname{DELAY}{ENTER} (works but all viewable)

I put my password into the Macro password field (it does display dots) and tried these macro strings

domain\username{TAB}{DELAY}%password%{TAB}{DELAY}hostname{DELAY}{ENTER} (doesn't enter anything in the password field)

domain\username{TAB}{DELAY}$mypassword${TAB}{DELAY}hostname{DELAY}{ENTER} (enters something in the password field but login fails)

Clock4 yrs

You haven't tried the macro password variable:
$MACRO_PASSWORD$

MacroPassword

David Hervieux

signaturesignature

MacroPassword.png
Clock4 yrs

The $MACRO_PASSWORD$ did the trick. I can successfully launch, connect and log in via RDM. Unfortunately, anyone with access to our RDM group can do the same.

Is there any way the credentials can be stored on my machine? The option to edit user specific or local machine specific sessions are not available. For instance, we use a RDM session for connecting to a vSphere and I can edit the User Specific or Local Machine Specific settings to put my own username/password in it.

Clock4 yrs

You could use the variable $PASSWORD$ if you enable it in Advanced. After that you could use the Local Specific Settings or the User Specific Settings. This will override the saved value.

David Hervieux

signaturesignature

Clock4 yrs

The option for editing User and Local Session settings is not available, only Edit Session.

RDM

What I am actually launching is a .jnlp (java) file. Normally, we connect to a URL and it downloads and executes that .jnlp file to launch the login screen. I tried putting the URL into an RDM session and it fails so launching the .jnlp file directly was my workaround. I tried using the Web Browser option (Firefox and IE) and Windows Explorer and neither will allow User or Local Session edits.

EDIT: I got it working using the URL but I still cannot edit the User or Local Session.
edited by robor007 on 4/5/2013
edited by robor007 on 4/5/2013

RDM.jpg
Clock4 yrs

Hi,
You right about Java Web Start, it does not allow User Specific Settings. However it works for me with the Web browser (http/https). Could you verify again with the setting Allow password in variable enabled in the Advanced tab page?

David Hervieux

signaturesignature

Clock4 yrs

I did get it working with the web browser using the URL to our CommCell server and directly launching the .jnlp file. It takes quite a bit longer to use the URL because it has to download a new .jnlp file each time but I just adjusted the wait time to compensate.

Regardless of which method (URL or .jnlp) I use I cannot edit the User Specific or Local Machine Specific Settings to store my credentials locally. Of course, that means anyone with access to RDM (which is everyone in our office) can use my session and log in as me.

I could modify the macro to not use my password so it has to be entered manually but I'm trying to make this a one-click thing and still maintain security.

Clock4 yrs

Could you send me an export (without the credential) of one session that work? I will verify why the User specific is disabled.

David Hervieux

signaturesignature

Clock4 yrs

I tried but when I right click the session and highlight Import/Export all of the options are grayed out.

Clock4 yrs

Could you manually setup a session in a blank xml file?

David Hervieux

signaturesignature

Clock4 yrs

I'll be happy to but I do not know how to do that. If you can you point me in the right direction I should be able to get it done.

Clock4 yrs

Go in File->Data Source

And create a new Xml data source in any folder. Send me the xml file created to support at devolutions.net

David Hervieux

signaturesignature

Clock4 yrs

I just sent you the requested xml data source.

Clock4 yrs

To anyone looking for this solution, rather than attempt to get the ability to edit User/Local Machine Specific Session for the CommVault connections I created them in my Local Data Source. Problem solved. Thank you to David for helping me get this working! smile

Clock4 yrs