Forum / Remote Desktop Manager - AddOns

OpenVPN Autologin Not Working

I've enabled autologin through the OpenVPN add-on, but it's not automatically logging me on, I still get prompted for creds. It notes that the creds are typed in (using a macro or something?) by the program, so you have to give it a sec, but I let it sit there and nothing happens. Is there another setting that has to be changed, maybe in the OpenVPN configuration itself?

Clock7 yrs

Hi,
The only way we have found to do the login is by auto typing the credentials. It's not possible to send them directly. Just to be sure i understand, does the credentials are typed?

David Hervieux

signaturesignature

Clock7 yrs

hi there,

i've got the same issue, the autologon works randomly.

Sometimes autologin is correctly filled, but 2 times on 3, the password is not filled.

I'm using RDM in a Virtual PC VM, with the RDM 8.0.12.0 and Open VPN 1.0.3

Clock6 yrs

Could you try the latest beta of RDM with the OpenVPN 1.4?

David Hervieux

signaturesignature

Clock6 yrs

Hello David,

i'm gonna test with the beta 8.0.17.0.

Which version of Open VPN do you mean ?
The latest OpenVPN GUI is the release 1.0.3

regards

Clock6 yrs

Hi,
Sorry I mean the latest Open VPN add-on in RDM is 1.4:

http://remotedesktopmanager.com/Home/AddOn#openvpn

David Hervieux

signaturesignature

Clock6 yrs

So i installed the Beta release 8.0.17.0 + latest Open VPN plugin and nothing has changed.

In the pop up "User authentication" the password is still not filled...

Clock6 yrs

Hi,
Do you see in RDM Send key dialog with the progress?

David Hervieux

signaturesignature

Clock6 yrs

no where is it ?

Clock6 yrs

This means that the Add-on does not try to send the credentials. Where have you entered the username/password? Directly in the add-on or it's linked to the credential repository?

David Hervieux

signaturesignature

Clock6 yrs

I've tested both.
But the problem is similar...

Clock6 yrs

RDM is looking for a Windows with this title:

OpenVPN - User Authentication

Could you verify if it's the current title?

David Hervieux

signaturesignature

Clock6 yrs

Yes that's it.

OpenVPN - User Authentication

Clock6 yrs

Does RDM is blocked. Can you move the main form?

David Hervieux

signaturesignature

Clock6 yrs

By the way, the most recent OpenVPN Gui version seems to be 2.3

http://openvpn.net/index.php/download.html

David Hervieux

signaturesignature

Clock6 yrs

Hello

i've installed the latest OpenVPN version and it seems that it's incompatible.
Now nothing is filled in login & password fields.
The authentication windows got a different name with this version (in french because i've got a French OS) : "Authentification d'utilisateur"
So RDM returns an error popup : "Unable to send credentials. Can't find the windows name: OpenVPN - User Authentication"

Regards

Clock6 yrs

Before that with the previous version; you haven't ever received the message "Unable to send credentials"?

David Hervieux

signaturesignature

Clock6 yrs

no, it was the first time i saw this message.

Regards

Clock6 yrs

Do you think that you could give a download link to download the version 1.0.3 that you have?

David Hervieux

signaturesignature

Clock6 yrs

Hello,

sorry for this late answer.

This is not the OpenVPN 1.0.3 it's the OpenVPN-Gui-1.0.3.
I'm using the OpenVPN 2.2.2.

Regards

Clock6 yrs

I want to test the same version than you. Do you still have the installer somewhere?

David Hervieux

signaturesignature

Clock6 yrs

yes you can download it here => http://dl.free.fr/nMZQxYDo2

Clock6 yrs

Hi,
It works fine for me with this version. However I found something confusing in the UI. Although you have credentials set, if you don't check "Enable automatic authentication", nothing will happen.

Could you verify that?

David Hervieux

signaturesignature

Clock6 yrs

Hi,

i confirm that nothing happen if this case is not checked..

But i've still the same issue in my side.
I'll send you in MP a little video of my problem

regards

Clock6 yrs

I have watched your video. So it seems that the user is sent but not the password? Could you try a really simple password for the test like 123456?

David Hervieux

signaturesignature

Clock6 yrs

i've changed the password to "1" but nothing changed.
The password field is still empty...

Clock6 yrs

Can you verify if the password text box has the focus?

David Hervieux

signaturesignature

Clock6 yrs

Yes the password text box got the focus.
I can see the flashing cursor in the password field.

Clock6 yrs

Ok,
One last question, could you type? I want to make sure that the dialog has also the focus.

David Hervieux

signaturesignature

Clock6 yrs

Sorry, i'm not sure that i understand your question.
Do you ask me if i'm able to type manually the password in the password field ?

If it is, yes, i'm able to enter manually the password.
edited by amobile on 3/5/2013

Clock6 yrs