Forum / Remote Desktop Manager - Bug Report

SAP GUI login - use env. variable in ini path

  • Create an Issue
  • Cancel

Hi,

When creating a SAP GUI login session I state %APPDATA%\saplogin.ini (and I have placed the saplogin.ini file in the path %APPDATA% refers to). The file can't be found so it seems %APPDATA% isn't used here?!?

When stating the full path %APPDATA% refers to the file can be found and the Connection list is populated.

Regards,
Jan-Pieter

Clock6 yrs

I have assigned this to André. He will look into it to resolve the env. variables.

David Hervieux

signaturesignature

Clock6 yrs

Hi,

Could you try this new version ?
Now it should works with environment variables.

You just have to replace the dll in %LocalAppData%\devolutions\RemoteDesktopManager\

But be careful you need the latest beta version to run it.

Best regards,

André Sanscartier

signaturesignature

SAPGui3.0.1.0.zip
Clock6 yrs

With this dll and RDM 9.4.9 I now can enter %APPDATA%\saplogin.ini however I have to click the dots to enter the file browse window and select the file. The %APPDATA% variable is then replaced by the actual path.
We would like to be able to leave the %APPDATA% variable (i.e. do not substitue it when setting up the session but evaluating it at the start of session) so everyone can use the entry no matter were %APPDATA% points to as long as everyone places the ini file there.

Clock6 yrs

Hi,
Sorry I don't have the environment to test it.
But I think that this last update should do the trick.
Please keep me informed.
I'll make required adjustments if needed.
Best regards,

André Sanscartier

signaturesignature

SAPGui3.0.1.1.zip
Clock6 yrs

When I type %APPDATA%\saplogin.ini the connection is populated however when I save I get "Unable to receive connection internal name".
If I save after selecting the actual file in the file browser (after which the path is expanded) I don't get this error.

Clock6 yrs

Hi,
I fixed the last issue. It should be able to save now.
After if unfortunately it doesn't open correctly I would know exactly what to do to fix it.
Sorry for any inconvenience.

André Sanscartier

signaturesignature

SAPGui3.0.1.2.zip
Clock6 yrs

Andre,

It does save now without having to change the %APPDATA%.

My environment isn't setup correctly either to test the actual connection. Enventually we will test this, maybe using the beta, maybe with the 9.5 release.

Regards,
Jan-Pieter

Clock6 yrs

Look like to old issue is back or hasn't been implemented correcly.

When I use 10.1.3.0 and type in %APPDATA%\saplogin.ini at "Saplogon.ini file" nothing happens. When I click the dots the correct path is displayed and the ini file is displayed. When selecting it the entry $APPDATA%\saplogin.ini is replaced by the actual path and file (so including the unwanted reference to my personal user) and I can see connections in the drop down.

Can you make it so we can leave the %APPDATA%\saplogin.ini?

Clock5 yrs

Hi,
Could you post few print screen to help me understand the issue?

David Hervieux

signaturesignature

Clock5 yrs

Hi,
What version of the add-on is installed ?
The SAP Gui Add-on V3.0.1.2 is required to use environment variables.
Regards,

André Sanscartier

signaturesignature

Clock5 yrs

Andre, David,

I stand corrected. With version 3.0.1.2 it works.

I was on a much lower level. After updating manually (somehow the automatic updated did not work) by downloading the zip file and moving the dll to c:\Users\{my user}\AppData\Local\Devolutions\RemoteDesktopManager\.
The add-on manager now shows green ticks before all three SAP Gui add-ons and no flags behind it. When I select the SAP Gui Add-on however the window shows a blue flag indicating an update is available. Is this because my manual update?

Regards,
Jan-Pieter

Clock5 yrs

image

Clock5 yrs

Hi,
No, it's normal.
This flag only indicates that an update has been released recently.
It corresponds to the website content.
It's the flag in the grid that is important.
Regards,

André Sanscartier

signaturesignature

Clock5 yrs