Forum / Remote Desktop Manager - Macro/Script/Tools

$PASSWORD$ variable session not understood ?

Hi,

I'm trying to configure WinSCP via Session Tools since I don't want to create 2 sessions for a computer (SSH + SCP).
For now, it doesnt work since I guess that the ^$PASSWORD$ variable is not replaced by its value.

Check out this example (sorry I can't upload pictures) in RDM 6.5.0.0 (Entreprise Trial) :

File test.cmd :
----------------
echo "Arg 1" %1
echo "Arg 2" %2
pause


Session Script tool :
-----------------------
Command line, Run : " "D:\test.cmd" $PASSWORD$ $HOST$ "

Result :
---------
D:\>echo "Arg 1" $PASSWORD$
"Arg 1" $PASSWORD$

D:\>echo "Arg 2" xdir-lutece03-r7
"Arg 2" xdir-lutece03-r7

D:\>pause


Is it a known issue ?

Clock8 yrs

For security reason with don't allow (except with the command line session) to extract the password. We have a small workaround for that. You can use the custom field in the Information tab page and set the password. The variable would be $CUSTOM_FIELD1$

David Hervieux

signaturesignature

Clock8 yrs

Thank you for your answer. I thought of using this workaround but I wanted to know if this behaviour is wanted.

So, we can't at all use the $PASSWORD$ variable in Session Script Tools ?

I'm failing to see the "security reason" if I want to use the password in command line and I am forced to used it clearly written in a custom field.

Clock8 yrs

Hi,
There is a small checkbox to hide the password in the custom field. I could add an option to allow the password in the variable. The would be disabled by default.

David Hervieux

signaturesignature

Clock8 yrs

David Hervieux wrote:

I could add an option to allow the password in the variable. The would be disabled by default.

It would be delightful smile.

I come from mRemoteNG and this is the only feature I miss. I'm switching to RDM to use the client/server feature in my whole company.

Clock8 yrs

Hi,
Could you try this version?

http://remotedesktopmanager.com/download/Setup.RemoteDesktopManager.6.5.1.0.exe

David Hervieux

signaturesignature

Clock8 yrs

Thank you for your quick update !!

I don't see the option to allow the password variable. Where is it located ?

Clock8 yrs

Hi,
It's in the session properties and in the Advanced tap page.

David Hervieux

signaturesignature

Clock8 yrs

Hi,

Thanks, it works like a charm !
But it is not available in batch processing, can you add it too smile ?
<em>edited by DeLoVaN on 9/28/2011</em>

Clock8 yrs

Good idea! I will add this for the next update

David Hervieux

signaturesignature

Clock8 yrs