Forum / Remote Desktop Manager - Feature Request

Request: Overriding the "always ask for password"

  • Create an Issue
  • Cancel

On some sessions we have configured for TS users "always ask for password" under the TS host configuration.

Example : http://dl.dropbox.com/u/63233/Remote/Passwordprompt.PNG

Despite the session being configured corretly in Remote Desktop Manager, the password is prompted (obviously) and password must be typed in.

Turning off the "always ask for password" fixes the problem.

The issue is that for some of out TS servers, the users must have this option set for compliance, but is not needed for us the sysadmins. Since the box popps up and asks for password could there be an additional option set in the program such as "is this TS configured to always ask for password?" And then if ticked, it autofills the box and sends the result to the server after it pops up? Not high priority I know, but may as well ask.

Kind Regards
Peter

Clock8 yrs

Hi,
Just to be sure, you want RDM to simulate the key press?

David Hervieux

signaturesignature

Clock8 yrs

There is a requirement that some staff (eg new starter) may need to access a server to do some work, but not know the password to login.

Here is what happens when I connect to a TS that has the "always ask for password" set.

1) Session info - note going through a gateway. http://dl.dropbox.com/u/63233/Remote/SessionInfoTS31.PNG
2) Login prompt (this is what needs to be overriden/removed somehow) http://dl.dropbox.com/u/63233/Remote/SavedCred.PNG

As you see, the TS will not allow the save credentials to be used. This is expected, but not desired. This may not be possible for you to "fix". I dont know...

Clock8 yrs

Any ideas on this one?

Pete

Clock8 yrs

I'm not sure, can you use the saved credential from mstsc.exe when you use it in external mode?

David Hervieux

signaturesignature

Clock8 yrs

No, and this would require each user to save the credential locally anyway even if this was possible (ie rather than in the SQL database)


Pete

Clock8 yrs

Hi,
I asking that just for a test, to see if the problem is on the destination.

David Hervieux

signaturesignature

Clock8 yrs

My apologies, I was not clear. I mean that no it is not possible, when you do this and tick save password you receive the exact same error as before. The server doesnt want you to be able to save the passwords and reprompts for it.

Clock8 yrs

Ok,
so the only way to achieve that is to simulate the key press or you have another idea?

David Hervieux

signaturesignature

Clock8 yrs

I have no other idea unfortunatly upset

Clock8 yrs

Can you try the Typing Macro, it's in the event tab page?

David Hervieux

signaturesignature

Clock8 yrs

Hi, I tried the typing macro. It would have been a good idea, but no matter what I type it doesnt put anything in the password prompt. Perhaps needs some tweaking? It also displays in clear text so would be nice if it could blank the password out.

Clock8 yrs

Hi,
I will allow it to blank the macro., but maybe it's just a matter of timing, try to add {Delay}{Delay}{Delay}{Delay} before

David Hervieux

signaturesignature

Clock8 yrs

Hmm, perhaps it is because we use the connections in tabbed mode. In external mode the {delay} command does add delay befre it types. In tabbed mode it just makes the connection take longer and longer to open. It doesnt type anything. I tried 40 dalays and left it for a while but no effect.

Pete

Clock8 yrs

Sorry,
I posted in the wrong page but I will try to do a test for the delay.
<em>edited by dhervieux on 7/21/2011</em>

David Hervieux

signaturesignature

Clock8 yrs

no worries i did wonder...

Clock8 yrs

Hey Dave,

Did you get a chance to take a quick look?

Pete

Clock8 yrs

Hi,
I tried but for now I'm unable to find a solution. I'm unable to get the right timing.

David Hervieux

signaturesignature

Clock8 yrs

Is this something that will ever be looked at in the future or should we give up on this?

Pete

Clock8 yrs

I never completely give up myself, something it takes month before I find a solution but for now I have no workaround... I forgot to post the message and in the meantime I fixed a bug. I think it will now be possible to simulate the keystroke. Check the next beta release please: 6.1.9.0

David Hervieux

signaturesignature

Clock8 yrs

Hi there

This is not fixed in 6.1.9

Pete

Clock8 yrs

No change in 6.5.1

Pete

Clock8 yrs

David Hervieux wrote:

I never completely give up myself, something it takes month before I find a solution but for now I have no workaround... I forgot to post the message and in the meantime I fixed a bug. I think it will now be possible to simulate the keystroke. Check the next beta release please: 6.1.9.0

Clock7 yrs

David, you mentioned the possiblity of 6.1.9.0 addressing this. Wea re running 7.0.3.0, but I can't see anything related to this. Can you give us an update? (This would be a very useful feature to us.)

Clock7 yrs

Hi,
this thread seems to contain multiple topics. Could you resume in one sentence the problem?

David Hervieux

signaturesignature

Clock7 yrs

Regarding the possibility of having Remote desktop Manager override the "always prompt for password" setting, perhaps for administrators only, or by simulating keyboard input:
* This feature would be very useful to us.
* You mentioned the possiblity of 6.1.9.0 addressing this.

We are running 7.0.3.0, but I can't see any change related to this. Can you give us an update?

Clock7 yrs

Hi,
I think that I was talking about the auto type macro feature. Could you give it a try?

http://help.remotedesktopmanager.com/autotypingmacro.htm

David Hervieux

signaturesignature

Clock7 yrs