Forum / Devolutions Password Server - Support

Credentials Lost After Upgrade

  • Create an Issue
  • Cancel

I recently purchased an upgrade from Remote Desktop Manager Enterprise to Remote Desktop Manager Server and before rolling it out to my company I am running some tests. So I created a backup of my current RDM database and restored it as a different DB name. I have RDMS pointed to the new database and everything is communicating and I can see my sessions. However I have one major problem, all my credentials (username/password) for my connections are missing. I can see them in the database but am unable to view them in the application and subsequently all my saved sessions (which link to the stored credentials) will not open without me manually entering the username and password. I need to know how to fix this as I would rather not re-enter 200+ usernames/passwords again.

If I create a normal SQL datasource instead of the RDMS datasource I can see everything as it was but then I cannot use AD groups for security.

Please help.

Chris

Clock6 yrs

Hi Chris,
Are you administrator? Could you try a Ctrl+Refresh button to force a clear of the cache?

David Hervieux

signaturesignature

Clock6 yrs

I have logged in as both an Administrator and a normal user, the problem is the same. I do not see them in the RDMS web page nor do I see them in the RDM application when connected to the RDMS datasource (http://<server>/rdms). When I connect to the database directly using SQL protocol I can then see all the credentials.

Are the credentials only viewable per user? Meaning if I create credentials for a session as userX while using a RDMS datasource can userY see them? In my testing it likes like no but need to know if I perhaps have something configured incorrectly.

Clock6 yrs

The credentials are visible by default by all the users. Could you verify if those credentials have a security group applied. Could you verify with the SQL Server connection

David Hervieux

signaturesignature

Clock6 yrs

After restoring the database again, I can now see all the previous credentials. Perhaps something got corrupted during the restore. Either way it is working now thanks for your assistance.

Clock6 yrs

This is really strange but I'm glad it works now.

David Hervieux

signaturesignature

Clock6 yrs