Forum / Remote Desktop Manager - Support

what is the "break" keyboard shortcut?

  • Create an Issue
  • Cancel

How do I issue the 'break' command inside SSH sessions when working on Cisco devices?
Is there a default in RDM? I'm using ssh connection type

Is there a reason I can't also click on the tab for the connection and go to 'special commands'? Why isn't "break" one of the special commands?

Clock2 mths

Hello,

The question might be strange but a break is not only doing a CTRL+C? If not, could you explain in which context the break feature is used?

This will help us understand the use case and I will be able to open a feature request.

Best regards,



David Grandolfo

signaturesignature

Clock2 mths

Hi David,

It's not a CTRL-C.

See my unresolved post here;
https://forum.devolutions.net/messages.aspx?TopicID=31661

Break is a special command (escape key) that can be send.
Same goes for backspace for example, which with default settings works for Cisco but not for some older HP (3Com) switches, which require Ctrl-H instead of Ctrl-? (127).

See this: https://www.cisco.com/c/en/us/support/docs/routers/10000-series-routers/12818-61.html

I haven't tried lately, the default for Cisco I believe is Ctrl-Shft-6


The context would be;

When you give a command, that spews out something and you want to cancel (break) the task.
Like for instance a Ping command or Traceroute

Clock2 mths

rolflobker is correct.
I have tried CTRL+C, CTRL+X, CTRL+SHIFT+ALT+X, CTRL+SHIFT+6, and all the other ones google says to try. Nothing works.

I need to break out of a ping or traceroute in Cisco devices and can't seem to be able to do it.

The 'special commands' area of the tab when right clicking the session tab would be a good spot for a 'break' command. In addition to actually being able to do it with a keyboard shortcut.

Clock2 mths

I found a way you can bypass it in the meantime, might be something you'd want to do by default;

In the configuration for the router or switch you can change the escape sequence;

conf t
line vty 0 15
escape-character 3


That makes it so Ctrl-C can be used. (apply same to console if required)


But this deviates from the norm, and requires changes to switches that not everybody might have access to, or would like to.


https://etherealmind.com/changing-break-sequence-cisco-ios-useful-different/


You might want to set this temporarily after logging in, using the macro typing option in RDM.
(which I use for example to send 'enable' on Cisco and 'terminal-length on HP switches)

To change the escape sequence for just the active session you would use;
terminal escape-character 3

Clock2 mths

First @rolflobker I apologize for the non-follow-up on your previous forum.

Thanks for the clarification both of you bring to this thread. I opened a ticket with the engineering department to add this feature request on RDM with the new SSH Engine.

As soon as I have further information I inform you.

Best regards,



David Grandolfo

signaturesignature

Clock2 mths

No worries about the non-follow-up, I also didn't follow up or remind anyone wink

Clock2 mths

why is it a feature request? Why do we need to wait for a new SSH engine?
My original question stands. How do you do this currently?
How does RDM send the break to the SSH session? And what RDM keyboard shortcut will make this happen.

Clock2 mths

The feature seems to be currently missing... so I'd consider it a request to get this implemented properly wink

I'm sure someone someone from the engineering department will know how to handle this, and David will monitor this and make sure the SSH engine gets a proper implementation of sending special sequences, because this (ssh/telnet) is an important part of RDM that needs to work properly.

Clock2 mths

You don't have to wait for the new SSH engine. It will be added to the SSH engine.

David Hervieux

signaturesignature

Clock2 mths

sorry, I guess I don't understand the difference. Was the previous post implying that RDM is working on a new SSH engine?
Or that the feature request would get implemented into the existing SSH engine that RDM uses?
Or both?

Clock2 mths

The feature request would get implemented into the existing SSH engine that RDM uses.


Regards

David Hervieux

signaturesignature

Clock2 mths

I just started a traceroute through an SSH session to a Cisco router.
Of course I forgot to temporarily change the Break command, so I now have no way of stopping this process on the router.

I know this is already on the "bug list" - just a reminder smile

Clock2 mths

This is my next task. I am currently closing my previous one and will work on this bug today, I don't know exactly how long it will take me to correct this, I'm guessing this should be done by the end of the week. Hope your unstopped process won't get tired util then wink

Regards

Denis Vincent

signaturesignature

Clock2 mths

any updates? think this will make it into a beta?

Clock2 mths

It's implemented and this will be soon available.

Regards

David Hervieux

signaturesignature

Clock2 mths

Great!

Just yesterday, I was logged into some Cisco routers using RDM and had to kill my sessions because I couldn't break the process.

Looking forward to this!

Clock2 mths


VERSION 2019.2.9.0 (October 10th 2019) Beta

•Added "send break" command for SSH shell entry


I tried this out immediately. Does not seem to work unfortunately.

Also; what would be the keyboard shortcut associated and how would we potentially change what the Break command is?


Clock2 mths

Hi,

Are you using the legacy terminal? Because the "send break" has not been implemented for it. But I think I did not understand your request correctly. Right now the "send break" sends an SSH break request, like what is done in the "special commands" menu of Putty. I thought you were referring to that, but it looks like its not the case. Do you have an example of a working break command in another terminal? Preferable Putty or OpenSSH. Or maybe you know the byte sequence sent on the wire?


As for using a keyboard shortcut, it is not possible right now, but I'm adding it to the feature request list. In fact, we are planning on a fully user customizable key shortcut table that could be used for that.

Regards!

Denis Vincent

signaturesignature

Clock1 mth

Hi,

I am currently doing research on special terminal keys. I wonder if you tried CTRL + 6 because there is a special handling in RDM's terminal for this key combination. The result is the same as CTRL + ^ which should be the same as CTRL + SHIFT + 6. I am a bit at the mercy of the OS for some key combination but I will resolve this.

Regards!

Denis Vincent

signaturesignature

Clock26 days

Sending the break command STILL doesn't work. Just updated to latest 2019.2.12.0

Tried
CTRL + X
CTRL + SHIFT + X
CTRL + SHIFT + ALT + X
CTRL + 6
CTRL + SHIFT + 6
CTRL + C
Right click the connection tab -> special commands -> send break

nothing works.

Clock13 days

Hi Hazen,

I had a chat with Denis and after research, we found that some Cisco router device uses different break commands as default [ Ctrl-Shift-6 (Ctrl-^) or Ctrl-Shift-6, X (^^X) ]. Moreover, some cisco device doesn't have any break command set.

Base on Cisco documentation https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/fundamentals/command/cf_command_ref/D_through_E.html looks at the section for Escape-character. Then give us in your cisco configuration, the value of the escape-character.

Best regards,



David Grandolfo

signaturesignature

Clock13 days

What does this mean for RDM? Is this feature just not going to be available then? Or will it just take RDM staff more time to figure out the best/right way? (rotate through different break sequences, let user select different types of break via the GUI, etc ?)

Clock13 days

Hello,

Unfortunatelly, we do not have the same device as you. We don't know what Cisco decided to use for this exact device as a break.

Could you give us your value "Escape-character"?

Regards,



David Grandolfo

signaturesignature

Clock13 days

So it works in putty, not sure why it doesn't work in RDM.

I am connecting to a WS-C2960X-24TS-L for example.
I issue the command "ping 1.1.1.1 repeat 1000"

a few seconds into the command running I can press SHIFT+CTRL+6 and the command will break out and stop.
If I do that exact same thing in RDM nothing happens.

So this isn't even a matter of Cisco having different commands. It works in putty, but doesn't work in RDM.

Clock13 days

Yeah PuTTY handles the key combo differently, I believe it just sends the "Break" key (actual Break key on keyboard) values over the line.

Just tried in a up-to-date RDM w/ SSH Shell Rebex , connected to a Cisco Router.
Ctrl-6 doesn't do anything
Ctrl-Shift-6 changes the tabname , it appends [B6]

Tried SSH Shell session;
Same effect as w/ rebex
Ctrl-Shift-6 does not work
Special commands > send Break does not break

You can try it by connecting to a cisco device (router, switch) w/ ping 127.0.0.8 , that will fail (2 second timeout) but take a bit longer than pinging something which responds. Gives you more time to try out the escape sequences
Try pingin 127.0.0.8 repeat 10 for a longer period (20 seconds) to test
Try ping 127.0.0.8 repeat 100 for agony because there's no way to cancel / break the running task....

This behaviour can be changed on most cisco devices, but this would be far from practical / ideal to require this modification when using RDM


SW-CORE-AMS-01#terminal escape-character ?
BREAK Cause escape on BREAK
CHAR or <0-255> Escape character or its ASCII decimal equivalent
DEFAULT Use default escape character
NONE Disable escape entirely
soft Set the soft escape character for this line


Looks like CTRL-SHIFT-6 is handled by RDM, when I notice the Tab name being changed to SessionName [B6]

I think the answer is somewhere in here; https://en.wikipedia.org/wiki/ANSI_escape_code#Escape_sequences
But man, that brings back memories

Clock13 days

I could be totally off here, but does this have anything to do with scancodes?
https://www.win.tue.nl/~aeb/linux/kbd/scancodes-1.html


Brk == e1 1d 45 e1 9d c5
The prefix e1 used for Pause/Break indicated that this key sends the make/break sequence at make time,


I think RDM captures the modifiers (shift-ctrl)
I do not know what the actual escape sequence is, and how it is send over SSH


https://bharathisubramanian.wordpress.com/2010/01/05/telnet-and-ssh-escape-sequences/

I am sorry I have nothing more usefull to add, I am not a programmer and do not know the first thing about escaping en how terminals/ ssh send their data.

But this is indeed a very frustrating issue, not being able to cancel any running tasks. And I presume this could affect other types of connections as well, but I dont very often run into other vendors' routers / switches where I need to Break tasks


Clock13 days

Thanks!

Knowing that ctrl + shift + 6 works in putty gives me the info I was looking for. I can't tell you right now when it will be fixed but I will work on it as soon as possible.

Regards.

Denis Vincent

signaturesignature

Clock12 days

@Everyone,
We found what “break” or catch the shortcut for the SSH Shell session. RDM catch the keyboard input and doesn’t transfer it to the session.
The first solution is to temporarily disable all the shortcut by clicking on the magnet.
The magnet is the icon at the bottom right of RDM.
Magnet+enable+disable
The second option is to disables shortcuts CTRL+6 under File -> Options -> User Interface Navigation or to set the option to When not in session
CTRL+6
And for CTRL+SHIFT+6
CTRL+SHIFT+6
Best regards,



David Grandolfo

signaturesignature

Magnet_enable_disable.jpg
CTRL+6.jpg
CTRL+SHIFT+6.jpg
Clock10 days

followed the instructions. Still doesn't work in RDM.

Clock10 days